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1 DCIBench Overview 

DCIBench is a tool that is utilized to create XML files with the expressed purpose of 
mapping COBOL file fields and DBMaker table columns. With the DCIBench 

generated XML files DCI can access the DBMaker database using MF COLBOL 
commands. 
DCIBench also provides users with a GUI (Graphical User Interface) to rapidly 

generate FD and SL data files.  
Within the DCIBench environment a code editor is provided to facilitate 
modifications that might be required to COBOL or XML source code. 

1.1 DCIBench: Graphic User 
Interface 
The main application window for DCIBench provides direct access to most of 
DCIBench’s functions. Toolbars, sub windows and other user interface elements can  
be docked, undocked, hidden, moved or made visible. The settings of DCIBench are 

retained from session to session.  

The Title Bar 

The Title Bar is located at the top of the screen and displays "DCIBench”, and the 
current name of the project, function, and program. The buttons on the right side of 

the title bar minimizes or maximizes the window and is used to close a program. 
 

 
Figure 1-1 Title Bar 
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The Menu Bar 

The Menu Bar is located directly below the Title Bar and displays DCIBench's drop-
down menus. Each menu contains a list of related commands. Menu commands can 
be displayed by left clicking with the mouse. The commands can also be accessed by 

holding down ALT+ (the corresponding underlined letter), then using the arrows 
keys to navigate up, down, left or right within the Menu Bar. Some menu 
commands are not active in certain contexts (grayed out) until the corresponding 

function or screen is used. 
 

 
Figure 1-2 Menu Bar 

The Toolbars 

DCIBench's Toolbars are located directly below the Menu Bar by default and are 

palettes of command buttons for commonly used functions. The Standard, Editor, 
and Launch toolbars can quickly execute commonly used actions. Each of the 
Toolbars can be displayed, hidden, moved, and resized. 

The various Toolbar buttons are enabled when an object with corresponding 
functions is used. A Toolbar is docked by default when selected, and can be hidden 
simply by removing it from the desktop. A Toolbar can be moved to a different 

docked position, or it can be floating; the size of a floating toolbar can also be 
altered.  

DISPLAYING TOOLBARS 
 

 
Figure 1-3 DCIBench’s Toolbars 

Â To display or hide the various toolbars: 

1. Select View from the Menu Bar, a drop-down menu appears. 

2. Select Toolbars, a drop-down submenu appears. 

3. Select the desired toolbar(s); the docked toolbar(s) appear(s). 

©Copyright 1995-2008 CASEMaker Inc. 1-2 
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MOVING TOOLBARS 
 

 
Figure 1-4 A Floating Toolbar 

Â To move a toolbar: 

1. Place the cursor over the embossed lines on the left side of a toolbar and 
depress the left mouse button. 

2. Drag the toolbar to the desired location and release the mouse button. 
Dragging it to the Canvas Area will create a floating toolbar; dragging it 
anywhere else, will automatically create a docked toolbar. 

RESIZING A TOOLBAR 
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Figure 1-5A Resized Toolbar 

Â To resize a toolbar: 

1. Move the pointer to the edge of a floating toolbar, the pointer changes to a 
double-headed arrow. 

2. Hold the left mouse button down. 

3. Drag the edge of the toolbar inward to make it smaller or drag the edge of the 
toolbar outward to enlarge it, until it is the desired size. 

4. Release the mouse button; the toolbar is resized. 

The Project Workspace 

The Project Workspace is where the most common functions and project 
management duties are accessed. It is a hierarchical document window providing 
object-oriented project management and editing functions. It consists the Data view. 

The Project Workspace opens on the far left of the desktop, just to the left of the 

©Copyright 1995-2008 CASEMaker Inc. 1-4 
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Figure 1-6 The Project Workspace 

THE DATA VIEW 
The Data View contains a hierarchical view of a project’s FD/SL file information. It 
also provides access to file and project management functions for a project. FD/SL 

file information is created using the File Designer and are stored in XFDXML layout 
files (“*”.xlt). To open an FD/SL file, in the File Designer, simply double click on 
the file in the Data View of the Project Workspace. 

DOCKING/UNDOCKING A PROJECT WORKSPACE 
A Project Workspace is docked on the far left of the desktop, just to the left of the 
Canvas Area. A Project Workspace can also be an undocked (floating) window. 

Â To undock a Project Workspace: 

1. Right-click in the Project Workspace, a pop-up menu appears. 

2. The Allow Docking check box is selected by default; remove the check mark 
to create a floating Project Workspace, the Project Workspace floats in the 
middle of the Canvas Area. 

3. Click and drag the edge of the Project Workspace to a desired position while 
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holding down the mouse button. 

4. Release the mouse button and the Project Workspace will float in place. 

Â To re-dock the Project Workspace: 

1. Right-click in the Project Workspace, a pop-up menu appears.  

2. Check on the Allow Docking check box, the Project Workspace. The Project 
Workspace is docked. 

The Canvas Area 

The Canvas Area is located in the center of the desktop by default and is where the 
most common functions and project management duties are performed. The File 
Designer and the Code Editor occupy the Canvas Area when they are active.   

The Output Window 

The Output Window is where all DCIBench’s standard output is displayed. The 
Output Window has three tabbed panes: Build, Find in Files and Launch Tools. The 
build pane displays messages when FD/SL and XML files are being generated. The 

Find in Files pane displays output generated form the Find in Files function of 
DCIBench. The Launch pane displays messages generated from tools launched from 
DCIBench. 
 

  
Figure 1-7 Output Window  

The Status Bar 

The Status Bar displays operating messages and hints when for any highlighted menu 
item. The Code Editor’s Status Bar displays Caps Lock mode, Num Lock mode, and 

Scroll Lock mode indicators. The modes can be toggled “on” or “off” by pressing the 
appropriate key on the keyboard. No indicator appears in Status Bar for a toggled 
“off mode”. The Status Bar also displays the total number of lines of code, the 

current column, and line position. 

©Copyright 1995-2008 CASEMaker Inc. 1-6 
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1.2 Customizing the GUI 
Many of the attributes and elements of DCIBench’s GUI (Graphic User Interface) 
can be customized to suit user preferences. Options can be set by using various right 

click pop up menus, the Options dialog box and the Customize dialog box. 

Customize Dialog Options 

The Customize dialog box is used to set user preferences for DCIBench’s toolbars. 
The Customize dialog box consists of three pages; Toolbars, Commands and, Tools. 

From the Toolbars page the toolbars for DCIBench can be hidden, made visible, 
new toolbars can be made or deleted and toolbar settings can be reset to their default 
values. 

From the Commands page customized toolbars can be created according to user 
preferences.  
In the Tools page the user can create new functions or commands for DCIBench’s 

toolbars. 

1.3 DCIBench Environment Options 
DCIBench’s environment options are divided into several categories, which include, 
General, Template, Build, Keyboard and Prefix options. 

General Environment Options 

The General environment options for DCIBench allow the user to control: 

• the timing of the automatic save function 

• the Recently Used Files list  

• what the workbench loads when it is first started and when it opens a workspace 

• the default source file format 

• the translation of ASCII extended characters to Windows ANSI extended 
characters 

Â To set General environment options: 
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1. Click Menu in the Menu bar. A drop down list appears. 

2. Select Options from the drop down list. The Options dialog box appears. 

3. Click the [+] Environment icon to expand the Environment options list. 

4. Select General from the Environment list. The General Environment 
options appear to the right of the list. 

5. Check the Save option box to activate automatic saves. The Automatic save 
every:_____minutes text box becomes active.  

a) Enter a new value into the Automatic save every:_____minutes text box 
if the default setting of ten minutes is not suitable 

6. If the default values of four in the Recently used lists fields are not suitable: 

a) Enter a value between one and eight in the Recently used files list. 

b) Enter a value between one and eight in the Recently used workspaces 
list. 

7. Select a radio button in the On start-up fields to specify what the DCIBench 
displays or loads when it is first started. 

8. Check the Reloads documents check box, in the On open workspace 
section, to direct DCIBench to reopen the documents that were open the last 
time the workspace was open. 

9. Specify the default source format type by selecting a radio button in the 
Default source format section. 

10. Check the Translate to ANSI/OEM, in the For extended ASCII characters 
section, to translate extended ASCII characters that originate in the OEM 
environment to Windows ANSI extended characters. 

11. Click OK to save current settings. 

12. Click Save … to save the current settings to a file that the user can specify.   

Template Environment Options 

Template environment options allow the user the to set preferences for: 

• use or bypassing of the New/File dialog box when creating new FD/SL’s or files 

• adding or customizing of templates for files 

Â To set Template environment options: 

©Copyright 1995-2008 CASEMaker Inc. 1-8 
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1. Click Menu in the Menu bar. A drop down list appears. 

2. Select Options from the drop down list. The Options dialog box appears. 

3. Click the [+] Environment icon to expand the Environment options list. 

4. Select Template from the Environment list. The Template Environment 
options appear to the right of the list. 

5. Check the New File check box to use the File/New dialog box when creating 
a new file. If this box is unchecked, by default, a blank file will be created 
each time the user tries to make a new file. 

6. Check the New FD/SL check box to use the File/New dialog box when 
creating a new file. If this box is unchecked, by default, a blank FD/SL will 
be created each time the user tries to make a new FD/SL. 

7. Use the buttons in the Customize template area to add, remove, or modify 
the set of file templates offered in the File/New dialog box. 

8. Click OK to save current settings. 

9. Click Save … to save the current settings to a file that the user can specify. 

Build Environment Options 

Build environment options allow the user to control certain aspects of how 
DCIBench behaves when running tools or generating FD/SL files. 

Â To set Build environment options: 

1. Click Menu in the Menu bar. A drop down list appears. 

2. Select Options from the drop down list. The Options dialog box appears. 

3. Click the [+] Environment icon to expand the Environment options list. 

4. Select Build from the Environment list. The Build Environment options 
appear to the right of the list. 

5. Check the Always save all documents check box to save documents when 
running tools in DCIBench. 

6. Select a radio button in the When generating the FD/SL files fields to 
specify how DCIBench behaves when generating FD/SL files. 

7. Click OK to save current settings. 

8. Click Save … to save the current settings to a file that the user can specify. 
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Keyboard Environment Options 

Keyboard environment options allow the user to view, define, redefine, or remove 
keyboard shortcut keys associated with DCIBench and DCIBench’s Code Editor 
commands. 

Â To set Keyboard environment options:  

1. Click Menu in the Menu bar. A drop down list appears. 

2. Select Options from the drop down list. The Options dialog box appears. 

3. Click the [+] Environment icon to expand the Environment options list. 

4. Select Keyboard from the Environment list. The Keyboard Environment 
options appear to the right of the list. 

5. Select the keyboard shortcut category, to be viewed, defined, redefined, or 
removed, from the Category drop down list. 

6. Select the short cut command, to be viewed, defined, redefined, or removed, 
from the Command field. The Shortcut key field becomes active. 

7. To assign a command: 

a) Enter a command in the Shortcut key field. 

b) Click Assign to assign a command. 

8. Click Remove to delete a shortcut key command.  

9. Click OK to save current settings. 

10. Click Save … to save the current settings to a file that the user can specify. 

Prefix Environment Options 

Prefix environment options allow the user to change the default file prefix strings 

and the default working directory names that are applied when the user creates a new 
project, FD/SL or file. 

Â To set Prefix environment options: 

1. Click Menu in the Menu bar. A drop down list appears. 

2. Select Options from the drop down list. The Options dialog box appears. 

3. Click the [+] Environment icon to expand the Environment options list. 

©Copyright 1995-2008 CASEMaker Inc. 1-10 
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4. Select Prefix from the Environment list. The Prefix Environment options 
appear to the right of the list. 

5. Assign the preferred prefix string in the Project prefix field for project 
prefixes. 

6. Assign the preferred prefix strings in the FD/SL prefix field for FD/SL 
prefixes. 

7. Assign the preferred prefix strings in the File prefix field for file prefixes. 

8. Enter the preferred name in the XML directory field for the XML directory 
name.  

9. Enter the preferred name in the FD directory field for the FD/SL directory 
name. 

10. Click OK to save current settings. 

11. Click Save … to save the current settings to a file that the user can specify. 

1.4 Code Editor Options 
Code Editor options for DCIBench are broken up into four categories: General, 
Format, Tabs and Keyword. 

General Code Editor Options 

The General Code Editor options that can be set by the user include: 

• modifying the width of the Line Number pane 

• modifying the length of a line in the Code Editor 

• setting the delimiter options for saving in a Windows or Unix environment 

• setting the vertical block behavior 

Â To set General Code Editor options: 

1. Click Menu in the Menu bar. A drop down list appears. 

2. Select Options from the drop down list. The Options dialog box appears. 

3. Click the [+] Code Editor icon to expand the Code Editor options list. 

4. Select General from the Code Editor list. The General Code Editor options 
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appear to the right of the list. 

5. Enter a value in the Line number pane width field if the default value of five 
is unsuitable. 

6. Enter a value in the Line length field if the default value of 318 is unsuitable. 

7. Set end of line options: 

a) Select the Save Record Delimiter as CR/LF radio button if saving in a 
Windows environment. 

b) Select the Save Record Delimiter as LF radio button if saving in a 
UNIX environment. 

8. Set the Virtual Space check box for an unlimited vertical block select. Clear 
the Virtual Space check box if the vertical block select function to is be 
limited to the width of the last line of the text block. 

NOTE Users make a block selection by holding down the ALT key and left click the 

mouse and the select the block of text to be edited or acted upon. 

9. Click OK to save current settings. 

10. Click Save … to save the current settings to a file that the user can specify. 

Format Code Editor Options 

Format Code Editor options allow the user to set options for: 

• setting the source file format 

• modifying the source file code 

• modifying the colour that identify each ANSI display field 

• customizing the text apperance of code types 

• designating the text string that is inserted in ANSI format when modifying 
source code 

Â To set Format Code Editor options: 

1. Click Menu in the Menu bar. A drop down list appears. 

2. Select Options from the drop down list. The Options dialog box appears. 

3. Click the [+] Code Editor icon to expand the Code Editor options list. 

4. Select Format from the Code Editor list. The Format Code Editor options 
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appear to the right of the list. 

5. Select the source format in the Source format drop down list. 

6. Check the Modify Code check box if the user wants to insert a specified 
character string in ANSI format columns 73-80 when a line of code is added 
or modified. Enter the desired string to be inserted in the adjacent entry field. 

7. Set the Format and Highlight settings by choosing a format from the list, 
select columns to be effected and the desired background and foreground 
colours. Clear the Enable “Format” and “Highlight” settings check box to 
disable these settings. 

8. Click the Font … button to select a different font setting. The Font dialog 
box appears. 

9. Set the Font, Font style and Size settings and click OK. The Options dialog 
box appears. 

10. Click OK to save current settings. 

11. Click Save … to save the current settings to a file that the user can specify. 

Tabs Code Editor Options 

Tabs Code Editor options allow the user to control support of the tabs in source 
code or automatically convert tabs in code to spaces. 

Â To set Tabs Code Editor options: 

1. Click Menu in the Menu bar. A drop down list appears. 

2. Select Options from the drop down list. The Options dialog box appears. 

3. Click the [+] Code Editor icon to expand the Code Editor options list. 

4. Select General from the Code Editor list. The General Code Editor options 
appear to the right of the list. 

5. Check the Display Tab character with check box to display a special 
character to indicate the location of a tab in the code. Insert a non-blank 
character in the accompanying entry field. 

6. Enter a value in the Tab size field if the default value of four is unsuitable. 

7. Select a source format from the Source format drop down list. Different sets 
of tab stops can be set for each source format. 

8. Set the Keep Tabs radio button if the Code Editor is to support the insertion 
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of tabs using the default tab size. 

9. Set the Insert spaces radio button if the Code Editor is to support the 
conversion of tabs to spaces or to set individual tab stops in the code. 

10. To add tab stops, enter each desired setting in the Tabs field and click Add. 

11. Click OK to save current settings. 

12. Click Save … to save the current settings to a file that the user can specify. 

Keyword Code Editor Options 

Keyword Code Editor options allow the user to add, delete, and modify keyword 

sets. Several default keyword sets are listed in the Keyword Set drop-down list. The 
user can also associate an indent value with a keyword and set an auto-indent 
behavior. The indent value is applied to the line following the keyword. 

Â To set Keyword Code Editor options: 

1. Click Menu in the Menu bar. A drop down list appears. 

2. Select Options from the drop down list. The Options dialog box appears. 

3. Click the [+] Code Editor icon to expand the Code Editor options list. 

4. Select Keyword from the Code Editor list. The Keyword Code Editor 
options appear to the right of the list. 

5. Click the Add… button to add a keyword set. The Add Keyword Set dialog 
box appears. 

a) Enter the keyword set name in the Keyword Set Name field. 

b) Specify the if the keyword set is copied from an existing internal or 
external keyword set by setting on of the radio buttons in the Copy 
From section of the dialog box. 

c) Click OK. The Options page appears. 

6. Click the New (Ins) button to add a keyword to a keyword set. 

7. Modify a keyword or it’s indent value by selecting the approriate field and 
entering a new value. 

8. Set automatic indent functions by setting one of the radio buttons in the 
Auto indent section of the dilaog box. 

9.  Click OK to save current settings. 
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10. Click Save … to save the current settings to a file that the user can specify. 

1.5 Data Designer Options 
Data Designer options allow the user to set 

• colours for copy files 

• element prefixes 

• elementary level settings for data items  

General Data Designer Options 

General Data Designer options allow the user to select the colours used to display 
linked items (items brought in via a COPY statement) included with the data 
designers. 

Â To set General data designer options: 

1. Click Menu in the Menu bar. A drop down list appears. 

2. Select Options from the drop down list. The Options dialog box appears. 

3. Click the [+] Data Designer icon to expand the Data Designer options list. 

4. Select General from the Data Designer list. The General Data Designer 
options appear to the right of the list. 

5. Select the colours used to display linked items from the Text Color drop 
down fields. 

6. Click OK to save current settings. 

7. Click Save … to save the current settings to a file that the user can specify. 

Graphical FD Data Designer Options 

Graphical FD Data Designer options allow the user to set the element prefix and the 
level-number interval settings for data items. 

Â To set Graphical FD data designer options: 

1. Click Menu in the Menu bar. A drop down list appears. 
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2. Select Options from the drop down list. The Options dialog box appears. 

3. Click the [+] Data Designer icon to expand the Data Designer options list. 

4. Select Graphical FD from the Data Designer list. The Graphical FD Data 
Designer options appear to the right of the list. 

5. Enter a prefix string in the Element Prefix field. 

6. Set the elementary level settings in the Elementary Level Settings section of 
the dialog box.  

7. Click OK to save current settings. 

8. Click Save … to save the current settings to a file that the user can specify. 
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2 Working with 
Projects 

This chapter of the user’s guide will address how a user will create, delete, modify 
and manage projects and their associated files.  

2.1 Project Management 
Creating a project is the first step in developing XML files in DCIBench. The most 
common functions and project management duties can be performed with pop-up 
menus in the Project Workspace. 

When the first project is created, a corresponding Project Workspace is automatically 
created. When creating subsequent projects, a choice of having it created in the same 
Project Workspace or creating a new Project Workspace can be made. An unlimited 

number of projects may be contained in each Project Workspace and each project 
can contain an unlimited number of data files. DCIBench’s Project Wizard can also 
be used to quickly create projects. 

2.2 The Project Workspace 
The Project Workspace is a hierarchical document window that provides object-
oriented project management and editing functions. It consists of the Data View.  
The Project Workspace opens on the far left of the desktop, just to the left of the 

Canvas Area, displaying Data View. It can be displayed, hidden, resized, and moved 
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to a different location on the desktop.  
NOTE Use the mouse to right-click icons in order to display pop-up menus, which can 

be used to perform common tasks more quickly. 

2.3 Creating a Project Workspace 
Workspaces are indirectly created when a project is created. To create a workspace 
you must create a project. The following conditions determine when a new 

workspace is created:  

• When a user creates a new project and no workspace is open, a workspace will 
be created by DCIBench. The new workspace will have the same name as the 

new project.  

• When a user creates a new project and a workspace is already open, the user will 
have the option of adding the new project to the active workspace or creating 
the project ina new workspace.  

When a new workspace is created, it is automatically assigned the same name as the 

project that created it.  

Opening a Project Workspace 

A Project’s contents are displayed in the Project Workspace area after selecting and 
opening a Project. 

Â To open the Project Workspace: 

1. Select File from the Menu Bar. A drop-down menu appears. 

TIP  To open a recent Project Workspace, select File from the Menu Bar, a drop-down menu 
appears. Select Open Recent Workspace, a sub-menu appears displaying the recently opened 
Project Workspace(s). Select the desired Project Workspace and go to step 5. 

2. Select Open Workspace, the Open Workspace dialog box appears, 
displaying the last Project Workspace opened in the directory window and 
the file type in the Files of Type drop-down list box. 

3. In the Look in drop-down list box, select a drive and directory path where 
the desired project is located. 

4. Click Open. 
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5. The Project Workspace opens on the far left of the desktop, just to the left of 
the Canvas Area. 

2.4 Creating Projects 
A project consists of one or more FD/SL files and its related XML file. Projects can 

be created using the project wizard or the user can create a blank project. 
The user can create a blank project from which the user can then add FD/SL files as 
the user sees fit. The user can also use the project wizard to generate projects. Using 

the project wizard the user is able to rapidly generate a project and import existing 
FD/SL files from a database or from files. 

Creating a Blank Project 

A blank project consists of the project file only. The user will be required to add 

other files to the project. 

Â To create a project: 

1. Select File from the Menu Bar. A drop-down menu appears. 

2. Select New from the drop down menu. The New dialog box appears. The 
Project portion of the dialog box is displayed by default. 
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3. Select the Blank icon. 

4. Enter a project name in the Project name field. 

5. Enter the project’s location in the Project name field. 

6. Enter a location for the project in the Location field. 

7. Enter a location for the FD files in the FD path field. 

8. Enter a location for the XML files in the XML path field. 

Creating a Project with the Project Wizard 

The Project Wizard is used to select and import existing FD/SL files into a project, 
by using a systematic process, to guide a user to rapidly generate projects. 

Â To create a project: 

1. Select File from the Menu Bar. A drop-down menu appears. 

2. Select New from the drop down menu. The New dialog box appears. The 
Project portion of the dialog box is displayed by default. 
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3. Select the Project Wizard icon. 

4. Enter a project name in the Project name field. 

5. Enter the project’s location in the Project name field. 

6. Enter a location for the project in the Location field. 

7. Enter a location for the FD files in the FD path field. 

8. Enter a location for the XML files in the XML path field. 

9. Select the Project Wizard icon. The Project Wizard – Select Cobol File 
dialog box appears. 

SELECTING COBOL FILES 
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• The Cobol/FD/SL File List lists all the files, and their paths, that have been 
imported in the project. 

• The Browse  button opens the Select Cobol Files dialog box. 

• The Remove Files  button in the Cobol/FD/SL File List portion of the 
dialog box allows a user to remove selected files from the Cobol/FD/SL File 
List. 

• The Clear  button removes all files from the Cobol/FD/SL File List. 

• The Mode field shows the data type of the imported files. By double clicking 
the Mode field of a selected file a combo box appears. The combo box allows a 
user to select the data type of the file (ANSI or Terminal). By default this 

combo box is set to Auto, so DCIBench automatically detects the file type for 
the user. 

• The Type field allows a user to select the type of COBOL file that is being 
imported. By double clicking the Type field of a selected file a combo box 

appears. The combo box allows a user to select the type of COBOL file that is 
being imported (FD or SL). By default this combo box is set to Auto so 
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DCIBench automatically detects the type of file for the user.   

• The Copy Path field indicates the location of the COPY file of the selcted 
COBOL/FD/SL file. 

• The Tab Size field indicates if a file has a “/t” character in it the specified tab 

size will be used. 

• The Associate All  button parses and associates all the FD and SL files in the 
Cobol/FD/SL File List. 

• The Associate Selected  button parses and associates selected FD and SL 
files in the Cobol/FD/SL File List.   

• The Available FD Layout List displays the FD files that have been successfully 

parsed and associated. 

• The Delete  button in the Available FD Layout List portion of the dialog 
box allows a user to remove selected files from the Available FD Layout List. 

•  The Delete All  button removes all files from the Available FD Layout 
List. 

• The Check All  button removes all files from the Available FD Layout List. 

• The Uncheck All  button removes all files from the Available FD Layout 
List. 

Â To add COBOL file to a project: 

1. Click the Browse  button. The Select Cobol Files dialog box appears. 
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2. Enter a file name in the File name field. 

3. Select the type of files to be imported from the Files of type combo box. 

4. Designate a search path for the project in the Search Path field if the selected 
COPY file includes other COPY files. 

5. Click Open. The selected file(s) appear in the Cobol/FD/SL File List. 

6. Click the Associate All  button. The parsed and associated files appear in 
the Available FD Layout List. 

7. Click the Check All  button so that all the files in the Available FD 
Layout List will be imported into the project. 

8. Click the Next button. The Project Wizard – Import Table dialog box 
appears. 

SELECTING TABLES 
The Project Wizard – Import Table dialog box allows a user to import files or tables 

from existing databases. 
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• The Data source information field indicates where the database is located.  

• The Browse  button opens the Data Link Properties dialog box. 

• Clicking the Check All  button selects all tables being imported to the 
project. 

• Clicking the Uncheck All  button unselects all tables being imported to the 
project. 

• The Table Name field shows the name of the table being imported. 

• The FD Record Name field shows the corresponding FD name of the selected 

table. The user can change the FD record file name for a table by double 
clicking this field for the selected table and entering and new record file name. 

• The Name field in the Column List shows the column names for the selected 
table being imported. 

• The Data Type field in the Column List shows the data type for the column. 

• The Picture field in the Column List allows the user to change the 

corresponding picture of the FD data item. The user can change the picture for 
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an FD data item by double clicking this field for the selected column and 
entering a suitable value. 

• The Type field in the Index List shows the keys and indexes on a table being 

imported. 

• The Field field in the Index List shows the table field being acted upon by a key 
or an index. 

Â To add a table from an existing database: 

1. Click the Browse  button. The Data Link Properties dialog box appears. 

 
2. Select the data link from the Provider tab.  

3. Click Next. The Connection tab appears. To specify the data source from the 
Data Source combo box go to step 4. To specify the data source from the 
Connection String field go to step 6. 
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4. Select a data source from the Data Source combo box. Continue to step 7. 

5. Click the Build button. The Select Data Source dialog box appears. 

 
a) Specify the data source location in the Look In combo box.  

b) Enter a DSN (Data Source Name) in the DSN Name field. 

c) Click the Machine Data Source tab. The Machine Data Source dialog 
box appears. 
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d) Select the data source from the Data Source Name list. 

e) Click OK. The Connection dialog box appears. 

6. Enter a username for the database in the User name field. 

7. Enter the password for the database in the Password field. 

8. Check the Blank password check box to allow a blank password for 
connection to the database. 

9. Check the Allow saving password to allow passwords to be saved when 
connecting to the database. 

10. Click the Advanced tab. The Advanced dialog box appears. 
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11. Set the network settings in the Network Settings portion of the dialog box. 

12. Set the connection time out limit in the Connect timeout field. 

13. Set the file access permissions in the Access permissions field. 

14. Click the All tab. The All dialog box appears. 
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15. The initialization properties for the data are shown. To edit a value select the 

initialization property to be edited and click the Edit Value button. The Edit 
Property Value dialog box appears. 

 
16. Enter the required value in the Property Value field. 

17. Click OK. The All dialog box appears. 

18. Click Ok. The Project Wizard – Import Table dialog box appears. 

19. Check the tables that are required for the project in the Table Names field. 

20. Click Finish. The new project appears in the Data View of the Project 
Workspace. 
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Project Properties 

Once a project has been created, using a blank project or the project wizard, the user 

can check the properties for the project. 

Â To check project properties: 

1. Right click the project folder in the project workspace. A pop up list appears. 

2. Select Properties… from the pop up list. The Project Properties dialog box 
appears. 

3. Enter a project name in the Project Name field if the project name is 
unsuitable. 

4. Enter a copy file path in the Copy Path field. 

5. Click OK to save the desired settings. 

Deleting a Project 

Deleting a project removes the project file and all associated files, such as the FD/SL 
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and XML files from DCIBench. 

Â To delete a project: 

1. Right click the project folder in the project workspace. A pop up list appears. 

2. Select Delete from the pop up list. The warning dialog appears asking if the 
user wants to remove the project from DCIBench. 

3. Click Yes to remove the project from DCIBench. The project is deleted from 
the workspace. 

2.5 File Descriptors 
Once a project has been created the user will now need to flesh out the project with 

file descriptors. 

Â To create a new FD/SL file: 

1. Select File from the Menu Bar. Or right click the project icon in the project 
workspace. A drop-down menu appears. 
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2. Select New from the drop down menu if proceeding from File. Select New 
FD/SL… from the menu if proceeding from the project icon. The New 
dialog box appears. The Project portion of the dialog box is displayed by 
default. 

 
3. Click the FD/SL tab. The FD/SL dialog box appears. 



 DCI for MFCOBOL User’s Guide1 

 
4. Click the Blank icon. 

5. In the FD/SL name field enter a name for the FD/SL file that is to be 
imported. 

6. In the Unique prefix field enter a prefix for the FD/SL file that is to be 
imported. 

7. In the Location field enter a file path for the new FD/SL file. 

8. Click OK. The new blank FD/SL file appears in the project workspace. 

Importing FD/SL Data 

There are several ways for a user to incorporate existing FD/SL files into a 

DCIBench project. These methods include: 

• Importing FD/SL data directly from an extisting XFD/XML layout file (.xlt) 

• Importing FD/SL data from a copy book (.fd and .sl) or COBOL code 

• Importing FD/SL data from a database directly 

Â To import data directly from a .xlt file: 

1. Right click the project folder in the project workspace. A pop up menu 
appears. 

2. Select Add FD/SL… from the pop up menu. The Add Data Layout to 
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Project dialog box appears. 

3. Select the file to be added to the project and click OK. The file appears in the 
project workspace. 

Â To import data from COBOL code: 

1. Select File from the Menu Bar. A drop-down menu appears. 

2. Select New from the drop down menu. The New dialog box appears. The 
Project portion of the dialog box is displayed by default. 

 
3. Click the FD/SL tab. The FD/SL dialog box appears. 
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4. Click the Import From Files icon. 

5. In the FD/SL name field enter a name for the FD/SL file that is to be 
imported. 

6. In the Unique prefix field enter a prefix for the FD/SL file that is to be 
imported. 

7. In the Location field enter a file path for the FD/SL file that is to be 
imported. 

8. Select a project for the file to be imported to from the Add to existing 
project combo box. 

9. Click OK. The Import FD/SL Files dialog box appears.  

 
10. To import a file from a pair of copy files (.fd and .sl) select the From copy 

file radio and continue to step 11. To import a file from a COBOL file select 
the From cobol source radio button and continue to step 13. 
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11. Click the Browse button in the .FD file path or the .SL file path fields. The 
Select FD file or Select SL file dialog box appears depending on which 
Browse button was selected. 

12. Select the file to be imported and click OK. The Import FD/SL Files dialog 
box appears. Continue to step 15. 

13. Click the Browse button in the Source file path field. The Select Source File 
dialog box appears. 

14. Select the file to be imported and click OK. The Import FD/SL Files dialog 
box appears. 

15. Click OK. The imported file appears in the project workspace. 

Â To Import FD/SL data from a database: 

1. Select File from the Menu Bar. A drop-down menu appears. 

2. Select New from the drop down menu. The New dialog box appears. The 
Project portion of the dialog box is displayed by default. 

 
3. Click the FD/SL tab. The FD/SL dialog box appears. 
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4. Click the Import From Database icon. 

5. In the FD/SL name field enter a name for the FD/SL file that is to be 
imported. 

6. In the Unique prefix field enter a prefix for the FD/SL file that is to be 
imported. 

7. In the Location field enter a file path for the FD/SL file that is to be 
imported. 

8. Select a project for the file to be imported to from the Add to existing 
project combo box. 

9. Click OK. The Data Link Properties dialog box appears. 
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10.  Select the data link from the Provider tab.  

11. Click Next. The Connection tab appears. Use data source name is selected by 
default. To specify the data source from the Connection String field go to 
step 14. 
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a) Select a data source from the Data Source combo box. Continue to 

step15. 

12. Select Use Connection String. The Connection String field and the Build 
button become active. 

a) Click the Build button. The Select Data Source dialog box appears. 

 
b) Specify the data source location in the Look In combo box.  
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c) Enter a DSN (Data Source Name) in the DSN Name field. 

d) Click the Machine Data Source tab. The Machine Data Source dialog 
box appears. 

 
e) Select the data source from the Data Source Name list. 

f) Click OK. The Connection dialog box appears. 

13. Enter a username for the database in the User name field. 

14. Enter the password for the database in the Password field. 

15. Check the Blank password check box to allow a blank password for 
connection to the database. 

16. Check the Allow saving password to allow passwords to be saved when 
connecting to the database. 

17. Click the Advanced tab. The Advanced dialog box appears. 
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18. Set the network settings in the Network Settings portion of the dialog box. 

19. Set the connection time out limit in the Connect timeout field. 

20. Set the file access permissions in the Access permissions field. 

21. Click the All tab. The All dialog box appears. 
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22. The initialization properties for the data are shown. To edit a value select the 

initialization property to be edited and click the Edit Value button. The Edit 
Property Value dialog box appears. 

 
23. Enter the required value in the Property Value field. 

24. Click OK. The All dialog box appears. 

25. Click OK. The Import From Database dialog box appears. 
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26. Select the table to be imported. 

27. Click OK. The imported FD/SL files appear in the project workspace. 

File Descriptor Properties 

Once FD/SL files have been created or imported the user can view the properties 

and, if required, modify the file name or the unique file prefix. 

Â To view and modify File Descriptor properties: 

1. Right click an FD icon in the project workspace. A pop up list appears. 

2. Select Properties… from the pop up list. The Data Layout Properties dialog 
box appears. 

3. Enter an FD name in the Name field if the FD name is unsuitable. 

4. Enter a prefix string in the Unique prefix field if the prefix string is 
unsuitable. 

5. Click OK to save the desired settings. 

Refreshing Files 

Refreshing files causes the selected data layout file (.dlt) to be rebuilt from it’s 
corresponding FD and SL files or COBOL file.  All files in a project can be refreshed 
at once or individual files can be refreshed as the user requires. 
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Â To refresh an individual file in a project: 

1. Select an FD file from the project workspace. The FD will be highlighted. 

2. Right click the selected FD file. A pop up list appears. 

3. Select Refresh. 

Â To refresh all files in a project: 

1. Right click the project icon in the project workspace. A pop up list appears. 

2. Select Refresh All from the pop up list. 

File Generation 

After creating a project and creating or importing FD/SL files for the project the user 

is now ready to generate files in the DCIBench environment. FD and SL files and 
most importantly XML files can be generated in DCIBench.  
There are several ways that files can be generated: 

• Individual FD or SL files can be generated 

• Individual XML files can be generated 

• All FD and SL files can be generated for an entire project simultaneously 

• All XML files can be generated for an entire project simultaneously 

• All FD, SL and XML files can be generated for an entire project simultaneously 

Â To generate an individual FD/SL file: 

1. Select the FD/SL file to be generated in the project workspace. The FD/SL 
will be highlighted. 

2. Right click the selected file. A pop up list appears. 

3. Select Generate FD/SL from the pop up list. 

TIP  DCIBench can also generate FD/SL files by right clicking in the File Designer while the file is 
active in the File Designer. Select Generate FD/SL from the pop up menu that appears to 
generate the file . 

Â To generate all FD/SL files for a project: 

1. Right click the project icon in the project workspace. A pop up list appears. 

2. Select Generate All FD/SLs. 
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Â To generate an individual XML file: 

1. Select the desired FD/SL file in the project workspace. The FD/SL will be 
highlighted. 

2. Right click the selected file. A pop up list appears. 

3. Select Generate XML from the pop up list. 

TIP  DCIBench can also generate XML files by right clicking in the File Designer while the file is 
active in the DCI page of the File Designer. Select Generate XML  from the pop up list to 
generate the file. 

Â To generate all XML files for a project: 

1. Right click the project icon in the project workspace. A pop up list appears. 

2. Select Generate All XMLs. 

Â To generate all FD/SL and XML files simultaneously: 

1. Right click the project icon in the project workspace. A pop up list appears. 

2. Select Generate All. 

Modifying Generated Files 

File modification in DCIBench is easily accomplished by using the File Designer or 
the Code Editor.  
Using the File Designer the user is able to utilize the graphical interface of the File 

Designer to rapidly modify FD, SL and XML files generated by DCIBench. Chapter 
6 gives an in-depth look at the File Designer.  
The Code Editor provides the user a more hands on approach to modifying the code 

generated by DCIBench. The user is able to see the raw code and make direct 
modifications that might be required. Chapter 5 provides a more detailed look at the 
Code Editor. 

Saving a Project Workspace 

A Project Workspace and its contents will automatically be saved upon closing or 
exiting the Project, or before generating FD/SL. It is still recommended that 
components be periodically saved to prevent the loss of work due to system 

limitations, malfunctions, or other unforeseen events. 
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Â To save a Project Workspace: 

1. Select File from the Menu Bar, the drop-down menu appears. 

2. Select Save Workspace to save the active (opened) Project Workspace and its 
components. 

Closing a Project 

Projects from within the Project Workspace may be individually closed. When 

closing a project, a pop-up confirmation dialog will appear for each unsaved FD/SL 
opened for the corresponding project. Closing projects or any other component is a 
good measure to save resources and to keep the Canvas Area and Project Workspace 

tidier for a more efficient work environment. 

Â To close a single project: 

1. Select a project from the Project Workspace; the project is highlighted. 

2. Right-click on the project node and a pop-up menu appears. 

3. Select Close Project. If any unsaved FD/SL’s exist, a pop-up confirmation 
dialog will appear with project name in the message. 

a) To save the changes, select Yes; the changes are saved and the 
component closes. 

b) To not save the changes, select No, the changes are not saved and the 
component closes. 

c) To cancel closing the project, select Cancel; the close is cancelled and 
the project remains open. 

4. The project and every component in the Canvas Area belonging to the 
project closes. 

Closing a Project Workspace 

Closing any component within the Project Workspace will simply close it and not 
save any of the changes until one of the save options has been chosen, whereas 
closing a Project Workspace will close all components contained within the Project 

Workspace. When closing a Project Workspace a dialog window appears displaying a 
list of all changed files, requesting a confirmation to accept each of the changes. 
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Â To close a Project Workspace: 

1. Select File from the Menu Bar. A drop-down menu appears. 

2. Select Close Workspace or Exit. The Close confirmation dialog box appears 
displaying all unsaved changes (this dialog box will only appear if there are 
unsaved changes). 

3. The dialog box contains a directory path with a check mark next to it for 
each FD/SL/project, select one of the following:  

a) Select Yes to save all changes.  

b) Select No to save none of the changes. 

c) Remove the check marks from the unwanted changes and select Yes to 
save the selected changes. 

4. The Close confirmation dialog box and the Project Workspace close. If the 
Exit option was chosen then DCIBench will also close. 
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3 The Code Editor 

This chapter introduces the components that are directly related to DCIBench Code 
Editor functions. These functions faciliate the generation and maintaince of FD, SL 

and XML files.  
The Code Editor windows containing source files appear in the Canvas Area of 
DCIBench. Each window element contributes to efficient source code generation 

and maintenance. 

The Ruler Bar 

The Ruler Bar appears at the top of each Code Editor window. It shows the current 
document's column numbers and tab settings for the document. The Ruler Bar can 

be displayed or hidden by setting or clearing the View -> RulerBar option. 

The Line Number Pane 

The Line Number Pane appears to the left of each Code Editor window. Each text 
line's number appears in this pane. The Line Number pane must be set for the line 

numbers to be visible. The Line Number Pane can be displayed or hidden by setting 
or clearing the View -> Line Number Pane option. 

The Bookmark Pane 

The Bookmark pane appears between the Line Number Pane and each Code Editor 

window. It contains the bookmarks that have been inserted in the code for reference 
and navigation purposes. The Code Editor displays an icon in the Bookmark pane to 
show that a line has been bookmarked. The Bookmark Pane can be displayed or 
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hidden by setting or clearing the View -> Bookmark option. 

The Output Window 

The Build tab of the Output window displays output messages related to various 

DCIBench functions. When code is being generated the generation status is 
displayed in the Output Window. 

Splitting the Window 

The Split function for the Code Editor literally splits the Code Editor window in 

two pieces. By splitting the Code Editor window the user is able to view and modify 
code in a more effiecent manner. Each portion of the window have their own scroll 
bars for easy code navigation. The Splitter is accessed by selecting Split from the 

Window, Menu Bar items.  

File Menu Commands 

The following is a list of the Code Editor commands available in the File menu 
command list. These commands will assit the user when modifiying or generating 

source code. 

• New: Opens a new source file 

• Open: Opens an existing source file 

• Close: Closes the active document 

• Save: Saves the contents of the active document 

• Save As: Saves a copy of the active document 

• Save All: Saves the contents of all open documents 

• Page Setup: Define headers, footers, and some page attribute settings for the 
active document 

• Print Setup: Change the printer and certain print properties 

• Print Preview: View the active document in its print format before printing  

• Print: Sends the active document to the printer 
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 Edit Menu Commands 

The following is a list of the Code Editor commands available in the Edit menu 
command list. These commands will assit the user when modifiying or generating 
source code.  

• Undo: Reverses previous editing actions 

• Redo: Reverses the most recent undo operation  

• Cut: Removes the selection from the active document and places it on the 
clipboard 

• Copy: Places a copy of the selection on the clipboard 

• Paste: Places a selection that has been cut or copied to the clipboard into the 
active document at the cursor location 

• Delete: Removes the selection from the active document 

• Select All: Selects all the elements in the active document 

• Find: Find multiple occurrences of a text string in the active document 

• Find Next: Advances to the next occurrence of the selected item in the active 

document 

• Find in Files: Locate text strings in files stored on drives 

• Replace: Replace items in the text with other items 

• Go To: Relocate the cursor at a specific destination in the active document  

• Bookmark: Insert a bookmark into the Bookmark pane for the selected line, 
move to the previous or next bookmark, or clear all bookmarks from the active 
document 

Format Menu Commands 

The following is a list of the Code Editor commands available in the Format menu 

command list. These commands will assit the user when modifiying or generating 
source code. 

• Capitalize: Capitalizes uncapitalized words in a selection  
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• Uppercase: Changes all lowercase characters in a selection to uppercase  

• Lowercase: Changes all uppercase characters in a selection to lowercase.  

• Comment Block: Select a block of text in your source code and apply comment 
symbols in the Indicator area  

• Uncomment Block: Remove comment markings from a block of text in source 

code that is currently marked for comment 

• Sequence Number: Re-number source code and display the new numbering in 
the Sequence Number area 

• Indent to Next: Changes the indent of the current line to match that of the next 
line  

• Indent to Previous: Changes the indent of the current line to match that of the 

previous line.  

• ANSI to Terminal Format: Toggles the foreground and background colors of 
source code between ANSI and terminal format, as was defined them in the 
Tools -> Options -> Code Editor -> Format options. 

Standard Toolbar Commands 

The Standard toolbar is a palette of command buttons for most commonly used 

word processing functions. You can display or hide the Standard toolbar by choosing 
the View/Toolbar/Standard command. You can also display or hide the Standard 
toolbar by right-clicking in the toolbar and choosing Standard, or by selecting 

Customize and then Standard in the Customize dialog box. The Standard toolbar 
contains the following commands:  

• The New  button opens the New dialog box.  

• The Open  button opens an existing file. 

• The Save  button saves the active file using its current file name. 

• The Save All  button saves all open files. 

• The Print  button sends the active file to a printer. 

• The Print Preview  button allows a view on an active file before printing. 
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• The Cut  button removes the selected item and places it on the clipboard. 

• The Copy  button places a copy of the selected item on the clipboard. 

• The Paste  button places a selection that has been cut or copied to the 
clipboard into the active file. 

• The Undo  button reverses recent editing actions. 

• The Redo  button reverses recent undo operations. 

• The Workspace  button toggles the view of the workspace in DCIBench. 

• The Output Window  button toggles the view of the Output window in 

DCIBench. 

• The Generate  button generates FD/SL files. 

• The Refresh  button refreshes files in DCIBench. 

• The About  button displays the DCIBench identification and copyright 
information. 

Editor Toolbar Commands 

The Editor toolbar commands allow users to quickly access commomly used text 
search and replace functions and bookmark management functions. 
 

• The Find  entry field allows users to enter the text 
string they want to find. It also allows users to select text from a drop-down list 

of recent search operations.  

• The Find Next  button advances the user to the next occurrence of the 
selected item in the active document. 

• The Find in Files  button allows the user to locate text strings in files stored 
on drives.  

• The Replace  button allows the user to replace items in the text with other 

items.  

• The Replace in Files  button allows the user to replace text strings in files 
stored on drives. 
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• The Toggle Bookmark  button inserts a bookmark into the Bookmark 
pane for the selected line.  

• The Go to Next Bookmark  button allows a user to automatically move the 

cursor to the next bookmarked line.  

• The Go to Previous Bookmark  button allows a user to automatically move 
the cursor to the previous bookmarked line.  

• The Clear All Bookmarks  button allows a user to clear all bookmarks from 
the active document.  

3.1 Working with Source Code 
DCIBench’s Code Editor provides users with an efficient, flexible and easy to use 

source code management environment. The DCIBench Code Editor provides users 
with all the functions necessary to find, insert, delete and modify source code.  

Navigating Text  

The following default keyboard commands allow users to move through text. The 

Command field in the table indicates the keyboard command found in Tools -> 
Options -> Environment -> Keyboard. The Shortcut Key field indicates which 
keyboard key(s) need to be pushed to execute the keyboard command. And the 

Action field of the table indicates the action that is preformed in the Code Editor 
when the shortcut is used. 
 

COMMAND SHORTCUT KEY ACTION 

CharRight Right Arrow 
Move one character to the 
right. 

CharLeft Left Arrow 
Move one character to the 
left. 

WordRight Ctrl + Right Arrow Move one word to the right. 

WordLeft Ctrl + Left Arrow Move one word to the left. 

LineEnd End 
Move to the end of the 
current line of text. 

Home Home Move to the beginning of 
h l f
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the current line of text. 

LineDown Down Arrow Move down to the next line.

LineUp Up Arrow 
Move up to the previous 
line. 

PageDown Page Down 
Move to the next page of 
text. 

PageUp Page Up 
Move to the previous page 
of text. 

DocumentEnd Ctrl + End 
Move to the end of the 
document. 

DocumentStart Ctrl + Home 
Move to the beginning of 
the document. 

GoToLine Ctrl + G 
Move to any specified 
location in the document. 

MOVING TO A SPECIFIED LOCATION 
By using the Edit -> Go To commands in DCIBench the user can move the cursor 

to the beginning, the end or to any specified line of text in the document. 

Â To move to the beginning of a document: 

1. With the Code Editor active in the Canvas Area, click Edit from the Menu 
bar. A pop up list appears. 

2. Highlight Go To from the pop up list. A sub menu appears. 

3. Select Begin from the sub menu. The cursor moves to the beginning of the 
document in the Code Editor. 

Â To move to the end of a document: 

1. With the Code Editor active in the Canvas Area, click Edit from the Menu 
bar. A pop up list appears. 

2. Highlight Go To from the pop up list. A sub menu appears. 

3. Select End from the sub menu. The cursor moves to the end of the document 
in the Code Editor. 

Â To move to any specified location in a document: 

1. With the Code Editor active in the Canvas Area, click Edit from the Menu 
bar. A pop up list appears. 
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2. Highlight Go To from the pop up list. A sub menu appears. 

3. Select Line from the sub menu. The cursor moves to the specified location in 
the document in the Code Editor. 

Using Bookmarks 

Bookmarkers are guides that the Code Editor allows users to insert to provide quick 

and simple navigation of source code text. These markers do not alter source code 
text in any way. These markers simply provide a more efficient manner for source 
code navigation. 

Bookmarks are only visible in the Bookmark Pane. The Code Editor displays a 
bookmark icon to indicate that a line of code has been bookmarked. Even if the 
Bookmark Pane is not visible bookmark navigation is possible. Bookmark navigation 

is not dependent upon bookmark visibility. 

Â To insert a bookmark into a document: 

1. With the Code Editor active in the Canvas Area, select the line of text to be 
bookmarked. 

2. Click the Toggle Bookmark button in the Editor Toolbar. The Bookmark 
icon is inserted. 

TIP  Display the Bookmark Pane if you want the bookmark icon to be visible beside the 
bookmarked line of text. 

Â To delete a bookmark from a document: 

1. With the Code Editor active in the Canvas Area, select the bookmarked line 
of text. 

2. Click the Toggle Bookmark button in the Editor Toolbar. The Bookmark 
icon is deleted. 

TIP  Display the Bookmark Pane if you want visible confirmation that the bookmark has been 
deleted. 

Â To clear all bookmarks in a document: 

1. Click the Clear all bookmarks button in the Editor Toolbar, with the Code 
Editor active in the Canvas Area. 

TIP  Display the Bookmark Pane if you want visible confirmation that all bookmarks has been 
deleted. 
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Using Tabs 

DCIBench’s Code Editor Tabs function provide another source for code navigation. 
Users can tab to the specified column by pressing Tab or Shift +Tab. The user can 
also set an interval for tab. This function is set in the Tools -> Options -> Code 
Editor -> Tabs  options. The Code Editor allows users to set and maintain different 
sets of custom tab stops for code in ANSI source format and terminal source format.  
Tabs may also be used to move blocks of text in source code. Highlight the lines of 

code to be moved and press the Tab key. The entire block of text shifts the number 
of places indicated in the Tools -> Options -> Code Editor -> Tabs options. 

Using the Splitter 

The Split function for the Code Editor literally splits the Code Editor window in 

two pieces. By splitting the Code Editor window the user is able to view and modify 
code in a more effiecent manner. Each portion of the window have their own scroll 
bars for easy code navigation.  

Â To split the Code Editor window: 

1. Select Window from the Menu Bar, with the Code Editor active in the 
Canvas Area. A pop up list appears. 

2. Select Split from the pop up list. A small bar appears in the Code Editor. 

3. Left click when the Code Editor is split in the desired proportions. 

3.2 Setting Page Options 
DCIBench supports the setting of header, footer, background and margin settings 
for sorce code pages.These settings alter the apperance of pages printed containing 

source code. 

Headers and Footers 

User have may options when setting headers and footers. The header and footer text 
alignment can be set. The text can be aligned to the left, right or to the centre of the 

page. The DCIBench supports headers and footers displaying the full file pathname, 
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the filename, the page number, the current time and the current date.  

Â To set header or footer options: 

1. Select File from the Menu Bar. A pop up list appears. 

2. Select Page Setup… from the pop up list. The Page Setup dialog box 
appears. 

3. Click the Browse  button. A pop up list appears. 

4. Select the elements to appear in the header or footer. 

TIP  After setting the page options click the Print Preview button in the Editor Toolbar to view the 
page before printing. 

Â To set the page appearance: 

1. Select File from the Menu Bar. A pop up list appears. 

2. Select Page Setup… from the pop up list. The Page Setup dialog box 
appears. 

3. Select a page style from the Style drop down list. 

4. Set the Print line number check box to print the source code line numbers. 

5. To “frame” the footers in a document make a selection from the Frame drop 
down list. The options available are determined by the Print line number 
option. 

6. Set the document’s margins if the default settings are unsuitable. 

TIP  After setting the page options click the Print Preview button in the Editor Toolbar to view the 
page before printing. 

3.3 Working with Text 
DCIBench’s Code Editor provides users with a flexible, easy to use source code 

editing and management environment. 

State Dependant Functions 

DCIBench integrates many development functions into a single FD/SL and GUI. 
These functions are dependant on the “state” of the DCIBench environment. The 

Open, Save, Close, Cut, Copy, Paste, Undo and Redo functions are state dependant 
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functions. When using these functions users must be aware of DCIBench’s current 
state.  

For example, if a user intiates a Save when in the Code Editor, the file that is 
currently being modified will be saved. If the user then switches to the File Designer 
and performs a save the files associated with the file active with the selected FD will 

be saved. Use Save All to save all open files. 

Opening Code Editor Files 

New and existing source code files can be opened in the Code Editor. When opening 
a new file users have the option of creating a blank new file or creating a file using a 

file template. 

Â To create a blank new source code file: 

1. Select File from the Menu Bar. A pop up list appears. 

2. Select New from the pop up list. The New dialog box appears. 

3. Select the File tab in the New dialog box. The File page is displayed. 

4. Select the Blank icon in the File page. The Blank icon is highlighted. 

5. Set the filename in the in the Filename field. 

6. Set the file path in the Location field. 

7. Click OK. The new file appears in the Code Editor. 

Â To create a source code file using a template: 

1. Select File from the Menu Bar. A pop up list appears. 

2. Select New from the pop up list. The New dialog box appears. 

3. Select the File tab in the New dialog box. The File page is displayed. 

4. Select the Template icon in the File page. The Template icon is highlighted. 

5. Set the filename in the in the Filename field. 

6. Set the file path in the Location field. 

7. Click OK. The new file appears in the Code Editor. 

Â To open an existing  source code file: 
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1. Select File from the Menu Bar. A pop up list appears. 

2. Select Open from the pop up list. The Open dialog box appears. 

3. Navigate to the desired file and click OK. The file appears in the Code 
Editor. 

Selecting Text 

Text can be selected using the mouse or by using the listed keyboard short cuts. The 
Command field in the table indicates the keyboard command found in Tools -> 
Options -> Environment -> Keyboard. The Shortcut Key field indicates which 

keyboard key(s) need to be pushed to execute the keyboard command. And the 
Action field of the table indicates the action that is preformed in the Code Editor 
when the shortcut is used. 
 

COMMAND SHORTCUT KEY ACTION 

CharRightExtend Shift + Right Arrow Select one character to the 
right. 

CharLeftExtend Shift + Left Arrow Select one character to the 
left. 

WordRightExtend Ctrl + Shift + Right Arrow Select one word to the right. 

WordLeftExtend Ctrl + Shift + Left Arrow Select one word to the left. 

LineDownExtend Shift + Down Arrow Select the next line or lines 
of text. 

LineUpExtend Shift + Up Arrow Select the previous line or 
lines of text. 

TIP  To perform a vertical block hold down the ALT key while dragging the cursor across the 
desired text. 

Moving Text 

The Cut, Copy and Paste functions allow users to move text in a document. Select 
the text in the document and  choose the required command from the Editor 
toolbar. 
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Deleting Text 

Deleting text is a very simple task. Select the text to be removed and push the Delete 
button on the keyboard or select Edit -> Delete. 

Changing Text Case and Indent 

The Code Editor allows users the change the case and indent of text without 

retyping the text. The text case and indent functions are all found in the Format 
Menu Bar pop up list. The options available are: 

• Capitalize: This option allows users to capitalize the first letter of the words in 

the selection. The remainder of the text will be in lower case letters. 
For example: 

Generated By Casemaker Dcibench 

• Uppercase: This option allows users to make all letters in the selection 
uppercase letters. 

For example: 
GENERATED BY CASEMAKER DCIBENCH 

• Lowercase: This options allows users to make all letters in the selection 
lowercase letters. 
For example: 

generated by casemaker dcibench 

• Indent to Next: This option allows users to set the indent of the selection to the 

indent of the next line of text. 

• Indent to Previous:This option allows users to set the indent of the selection to 
the indent of the previous line of text. 

Text Block Handling Functions 

The Code Editor has text block handling functions that allow users to manipulate 
source code in a variety of ways. Use the Format/Comment Block or 

Format/Uncomment Block commands to add comment markings to or delete 
markings from a selected block of text. The Format/ANSI to Terminal Format 
command toggles the foreground and background colors of source code between 
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ANSI and terminal format, as were defined them the Tools-> Options -> Code 
Editor - > Format options. 

Working with COPY Files 

Users are able to open COPY files from the Code Editor or the File Designer. To 
open a COPY file users must first set the correct COPY file path in the Project 
Properties dialog box. The COPY file functions are located in a pop up menu that is 

located in the Code Editor and the File Designer. While in the File Designer or the 
Code Editor a user simply right clicks in the Canvas Area for the pop up window to 
appear. 

Source Code Templates 

Users are able to add existing source code files to new text files as a template through 
the Tools -> Options -> Environment -> Template interface. The Add option in the 
interface allows users to open the Add New Template File dialog box. Using the 

dialog box, users are able to import the desired file. The file will appear in the 
interface and in the File -> New -> File dialog box. 
After creating the file it can be deleted or modified in the Template interface. For 

more information about the Template interface see Chapter 3.3. 

Searching for Text 

DCIBench provides two utilities for locating text in files and replacing that text if 
desired. The first searches for a string in a file that is open in the Code Editor. The 

second searches for a string in any readable file located in the specified directory or 
device. Both facilities support the use of operators and special characters in the search 
string.  

SEARCH STRING OPERATORS  
Search string operators are wildcards that can be used to match special conditions or 
multiple conditions. The following operators can be used individually or in groups 

to help facilitate the search.  
The following table lists the operators available to users. To select an operator, set 
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the Regular expressions check box in the Find, Find in Files, Replace and Replace in 
Files dialog boxes. Click the Browse button to the right of the "Find what" entry 

field, and select an operator from the list. 
 

EXPRESSION LIST ELEMENT ACTION 

. Any Character Matches any character. 

[  ] Character in Range Matches any character in 
the specified range. 

[ ^ ] Character Not in Range Matches any character not 
in the specified range. 

^ Beginning of Line Matches the beginning of 
the specified string. 

$ End of Line Matches the end of the 
specified string. 

\ < Beginning of Word Matches the beginning of 
the specified word. 

\ > End of Word Matches the end of the 
specified word. 

\ [ \ ] Tagged Expression Matches the specified 
expression. 

* 0 or More Matches Matches any character zero 
or more times. 

+ 1 or More Matches Matches any character one 
or more times. 

\ Quoted String Matches the quoted string. 

Â To find a text string in an active file: 

1. Move the cursor to the location where the search will begin. 

2. Click Edit from the Menu bar. A pop up list appears. 

3. Select Find from the pop up list. The Find dialog box appears. 

4. Enter the text string to be search for in the Find what field. 

5. Set the Match case check box to find the exact specified text string. 

6. Set the Regular expression check box and select an expression from the 
expression list to use an expression to facilitate the search. 

7. Set the Wrap around search check box to have the search start from the 
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beginning of the document after the seach has reached the end of the 
document. 

8. Set the Ignore `-' and `_' check box to direct the search operation to ignore 
hyphens and underscores. 

9. Select the desired direction of the search using the Up and Down radio 
buttons in the Direction section of the dialog box. 

10. Click the Find Next button to search for the desired text string. Click the 
Find Next button again to find the next occurrence of the desired text string. 

TIP  Clicking the Mark All button will mark each line of text with the desired text string,in the 
Code Editor, with a bookmark. 

 

TIP  Clicking the Find All button will  direct the search operation to find all occurences of the 
desired text. The results of the search will be displayed in the Find in Files pane of the Output 
Window. 

Â To replace a text string: 

1. Move the cursor to the location where the search will begin. 

2. Click Edit from the Menu bar. A pop up list appears. 

3. Select Replace from the pop up list. The Replace dialog box appears. 

4. Enter the text string to be search for in the Find what field. 

5. Enter the replacement text string in the Replace with field that is to replace 
the text in the Find what field. 

6. Set the Match case check box to find the exact specified text string. 

7. Set the Regular expression check box and select an expression from the 
expression list to use an expression to facilitate the search. 

8. Set the Wrap around search check box to have the search start from the 
beginning of the document after the seach has reached the end of the 
document. 

9. Set the Ignore `-' and `_' check box to direct the search operation to ignore 
hyphens and underscores. 

10. Select the desired direction of the search using the Up and Down radio 
buttons in the Direction section of the dialog box. 

11. Click the Find Next button to search for the desired text string.  

12. Click Replace to replace the text in the Find what field with the text in the 

©Copyright 1995-2008 CASEMaker Inc. 3-16 



1The Code Editor 3 

©Copyright 1995-2008 CASEMaker Inc. 3-17 

Replace with field. 

13. Click the Find Next button again to find the next occurrence of the desired 
text string. 

TIP  Click Replace All to replace every occurrence of the text in the Find what field with the text in 
the Replace with field.  

Â To find a text string in all files: 

1. Move the cursor to the location where the search will begin. 

2. Click Edit from the Menu bar. A pop up list appears. 

3. Select Find in Files from the pop up list. The Find in Files dialog box 
appears. 

4. Enter the text string to be search for in the Find what field. 

5. Select the type of file to be searched in the File types drop down list. 

6. Set the Match case check box to find the exact specified text string. 

7. Set the Regular expression check box and select an expression from the 
expression list to use an expression to facilitate the search. 

8. Set the options in the Where section of the dialog box 

a) Select the Search in workspace radio button to seach for the text string 
in a file that is in DCIBench. Continue to step 11. 

b) Select the Search in directories radio button to search for the text string 
in a specific directory. The Search directories options section of the 
dialog box becomes active. Continue to step 9. 

9. Select the directory to be searched in the Look in field. Or click the Browse 
button for further search options 

10. Set the Include subdirectories check box to include the subdirectories in the 
search. 

11. Click the Find button to search for the desired text string. The results of the 
search are displayed in the Find in Files pane of the Output Window. 

Â To replace a text string in all files: 

1. Move the cursor to the location where the search will begin. 

2. Click Edit from the Menu bar. A pop up list appears. 

3. Select Replace in Files from the pop up list. The Find in Files dialog box 
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appears. 

4. Enter the text string to be search for in the Find what field. 

5. Enter the replacement text string in the Replace with field that is to replace 
the text in the Find what field. 

6. Select the type of file to be searched in the File types drop down list. 

7. Set the Match case check box to find the exact specified text string. 

8. Set the Regular expression check box and select an expression from the 
expression list to use an expression to facilitate the search. 

9. Set the options in the Where section of the dialog box 

a) Select the Search in workspace radio button to seach for the text string 
in a file that is in DCIBench. Continue to step 12. 

b) Select the Search in directories radio button to search for the text string 
in a specific directory. The Search directories options section of the 
dialog box becomes active. Continue to step 10. 

10. Select the directory to be searched in the Look in field. Or click the Browse 
button for further search options 

11. Set the Include subdirectories check box to include the subdirectories in the 
search. 

12. Click Replace All to replace every occurrence of the text in the Find what 
field with the text in the Replace with field. The results of the operation are 
displayed in the Find in Files pane of the Output Window. 

Finding Matched Verb Block Command Lines 

Users can move the cursor automatically to the opposite end of a matched verb block 
command line. Matched verb blocks are pairs of commands that begin and end a 

statement. DCIBench recognizes the following list of matched verbs as pairs: 
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INITIAL STATEMENT END STATEMENT 
Add  End-Add 

Call  End-Call 

Evaluate  End-Evaluate 

If  End-If 

Perform  End-Perform 

Read  End-Read 

Return  End-Return 

Rewrite  End-Rewrite 

Search  End-Search 

Start  End-Start 

String  End-String 

Write  End-Write 

Previewing Files Before Printing 

DCIBench supports the previewing of an opened file before printing. Using this 
option will give users a graphical representation of an opened document before it is 
printed. The user has several options when viewing the page including zooming in, 

zooming out and printing directly form the Print Preview page. The table below 
details the options available to users. 
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OPTIONS ACTION 
Print Clicking this button sends the active document to a 

printer. 

Next Page Clicking this button allows the user to advance to the next 
page in the active document. 

Prev Page Clicking this button allows the user to retreat to the 
previous page in the active document. 

Two Page Clicking this button allows the user to view to pages of the 
active document simultaneously. 

One Page Clicking this button allows the user to view a single page of 
the active document. This button is only active when the 
user has clicked the Two Page button and is viewing two 
pages from the active document. 

Zoom In Clicking this button allows the user to zoom in for a closer 
look at the active document. 

Zoom Out Clicking this button allows the user to zoom out for a 
broader look at the active document. 

Close Clicking this button closes the Print Preview page. 

Â To preview an active file: 

1. With an active document in the Code Editor, select File from the Menu Bar. 
A pop up list appears. 

2. Select Print Preview from the pop up list. The Print Preview page opens 
with the active document appearing in the page. The user has several options 
when viewing the page. Refer to the table above for more details. 
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4 File Designer 

The File Designer is used to define the physical files contained within a project, 
including file-control-entries, file-description-entries, keys, and XML files. 

The file designer consists of three sections, File Control, Definition, and DCI. 
The File Control section of the File Designer deals with the SL files and record keys 
in a project. The Definition section of the File Designer handles the FD files for a 

project. Finally the DCI section deals with XML file options and generation. 

4.1 Opening the File Designer 
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Â To open the File Designer: 

1. First expand a project in the Data View of the Project Workspace. This can 
be accomplished in two ways: 

a) Click the [+] to expand a project in the Data View of the Project 
Workspace. 

b) Double-click the project icon in the Data View of the Project 
Workspace.   

2. Double-click a file icon in the expanded project. The File Designer appears. 

Creating Files 

DCIBench can be used to manipulate and generate FD/SL files with the File 
Designer. 

Â To select an FD/SL file: 

1. Select File from the menu bar. A drop-down menu appears. 

2. Select New. The New dialog box appears. 

3. Click the FD/SL tab and select the Blank icon. 

4. Enter an FD/SL file name in the FD/SL Name text box. 
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5. Enter a file path in the Location text box to specify the location of the FD/SL 
file and proceed to the next section, or search for a location by clicking 
Browse and proceed to step 6.  

6. The Choose Directory dialog box appears. Select a location and click OK, 
the Choose Directory dialog box closes and the new path is displayed in the 
Location text box. 

7. Click OK, the FD/SL file is added to the current project and the File 
Designer opens in the Canvas area. 

4.2 File Definition 
The Definition screen is used to define the file's record structure. 

 

 

Setting FD/SL File Definitions 

The File Definition page in the File Designer is used to define a file’s record 
structure. Ensure that the File Definition page is displayed and select any of the 

options that follow. 
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SPECIFYING A FILE FORMAT 
Select a file format from the Format drop down list. Specifying a file format in the 
File Definition page will carry over to the File Control page. For more information 

on specifying file formats refer section 6.3 File Control. 

Â To specify a file format: 

1. Select a file format from the Format combo box. The selected file format 
appears in the drop-down list box. 

ADVANCED OPTIONS 
The Advanced Options dialog box allows users to specify additional definition screen 
options for the selected entry. 

Â To set Advanced options: 

1. Click the Advanced button. The Advanced dialog box appears. 

2. The Declared section of the dialog box allows users to select file declaration 
options. 

a) Set the External check box to include the IS EXTERNAL phrase. 

b) Set the Global check box to include the IS GLOBAL phrase. 

c) Set the Thread-Local check box to include the IS THREAD-LOCAL 
phrase. 

3. The Detailed Attribute area of the dialog box allows users to select file 
description entry phrases. 

a) Set the Block check box to include the BLOCK CONTAINS phrase. 
This option is only available for sequential files. 
Enter the minimum and maximum block size in the entry fields to the 
right. 
Enable the appropriate radio button to specify physical record size in 
terms of either logical records or characters. 

b) Set the Code-Set check box to include the CODE-SET phrase. 
This option is only available for sequential files. 
Enter the name of the desired SPECIAL-NAMES character set in the 
Name field. 

c) Set the Label check box to include the LABEL-RECORDS phrase. 
The LABEL-RECORDS phrase is ignored by the compiler. 

d) Set the Linage check box to include the LINAGE phrase.  
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This option is only available for sequential files. 
In the entry fields to the right, specify the number of lines on a page, the 
line number where the footing area begins on the page, and the numbers 
of lines in the top and bottom margins. 

e) Set the Record check box to include the RECORD phrase. 
Specify the record size in the Record area the right. 
Enable the Contain radio button to specify the size of a variable-length 
record. 

f) Set the Recording Mode check box to include the RECORDING 
MODE phrase. 

g) Set the Value of File-ID check box to include the VALUE-OF-FILE ID 
phrase. 

4. Click OK to save the specified options. 

ADDING A COMMENT 

Â To add a comment to a generated FD file: 

1. Click the Comment button. The Comment dialog box appears. 

2. Enter a comment and click OK when finished. 

ADDING A DATA ITEM 

Â To add a Data Item: 

1. Select the Add Item tab to add a data item, a drop-down list appears. Select a 
level item from the list, the data item appears in the Data Item Definition 
dialog box (Selecting the Level 1 data item will add a second Level 1 data 
item under it). 

2. To add a data item above another data item highlight the desired data item 
and click the Add Item Before icon, the new data item appears above the 
highlighted data item in the Data Item Definition dialog box. 

3. To add a data item after another data item highlight the desired data item 
and click the Add icon, the new data item appears below the highlighted data 
item in the Data Item Definition list dialog box. 

4. To add a sub-item, highlight a parent data item, and click the Add Sub-Item 
icon, the sub –item appears below the parent data item in the Data Item 
Definition dialog box. 
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CHANGING A DATA ITEM LEVEL 

Â To change the Level of a Data Item: 

1. Select a data item in the Data Item Definition dialog box; the Data Item is 
highlighted. (The first Level 01 cannot be changed). 

2. Double-click the level number in the Level column; the number is no longer 
grayed-out and is made accessible. 

3. Type a new level number and click anywhere outside of the Level column, 
the data item level changes. 

RENAMING A DATA ITEM 

Â To rename a Data Item: 

1. Select a data item in the Data Item Definition dialog box; the Data Item is 
highlighted. 

2. Double-click the data item name in the Field Name column; the Field Name 
column is no longer grayed-out and is made accessible. 

3. Type a new data item name and click anywhere outside of the Field Name 
column, the data item name changes. 

MODIFYING A PIC SIZE 

Â To modify a PIC size: 

1. Select a data item in the Data Item Definition dialog box; the Data Item is 
highlighted. 

2. Double-click a PIC in the PIC column; the PIC is no longer grayed-out and 
is made accessible. 

3. Type a new PIC size and click anywhere outside of the PIC column, the PIC 
changes. 

SPECIFYING USAGE OPTIONS 

Â To specify Usage options: 

1. Select a data item in the Data Item Definition dialog box; the data item is 
highlighted. 

2. Double-click the Usage column in the data item row, a drop-down list 
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appears. 

3. Select an option from the Usage drop-down list. The assigned Usage option 
appears in the Usage column. 

SETTING A DATA ITEM VALUE 

Â To set a Data Item Value: 

1. Select a data item in the Data Item Definition dialog box; the Data Item is 
highlighted. 

2. Double-click the Value column in the Data Item row; the Value column is 
no longer grayed-out and is made accessible. 

3. Enter a value and click anywhere outside of the Value column, the value will 
be set and appear in the Value column. 

REDEFINES Clause 

A REDEFINES clause creates multiple definitions for the same field. 

REDEFINING A DATA ITEM 

Â To Redefine a data item: 

1. Select a data item in the Data Item Definition dialog box; the Data Item is 
highlighted. 

2. Double-click the Redefine column in the data item row, a list appears 
displaying the data item that appears directly above the selected data item 
corresponding with the level. If no data item of the same level exists directly 
above the selected data item within the same context then no items will be 
listed.  

3. Select the data item from the Redefine list, click anywhere outside of the 
Redefine column, the data item is will be redefined, and appear in the 
Redefine list. 

OCCURS Clauses 

The OCCURS clause allows a field to be defined as many times as the user wants. 
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SETTING OCCURS SYNTAX 

Â To set Occurs Syntax: 

1. Select a data item in the Data Item Definition dialog box; the Data Item is 
highlighted. 

2. Double-click the Occurs column in the data item row; the Occurs column is 
no longer grayed-out and is made accessible. 

3. Select a data item from the Occurs list box. If the list box is empty, click the 
Browse button, the Occurs Syntax dialog box appears. 

4. Select the Occurs Clause check box (), in the Occurs Syntax dialog box; the 
fields are no longer grayed-out and are made accessible. 

5. Set the desired Occurs Syntax settings and click OK, the Occurs Syntax 
dialog box closes. 

6. Click anywhere outside of the Occurs column in the File Designer, the 
options will be set and appear in the Occurs column. 

SETTING THE FIELD ADVANCE OPTIONS 

Â To set Field Advance options: 

1. Select a data item in the Data Item Definition dialog box; the Data Item is 
highlighted. 

2. Double-click the last column in the data item row. The Field Advance dialog 
box appears. 

3. Set the Global check box to include the IS GLOBAL phrase. 

4. Select a name from the Special Names drop down list for the IS SPECIAL-
NAMES phrase. 

5. Select a sign position from the Sign drop down list for the SIGN IS phrase. 

6. Set the Justified right check box to include the JUSTIFY RIGHT phrase. 

7. Set the Blank when zero check box to include the BLANK WHEN ZERO 
phrase. 

8. The Copy File section of the dialog box is active only if the selected item is 
part of a linked COPY file. From that section users can: 

a) Set the Convert Link to Import to convert a linked COPY file to an 
imported COPY file. 
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9. Enter any desired text comment in the Comment text box. 

10. Click OK. The Field Advance dialog box is closed, and the options are set. 

DELETING A DATA ITEM 

Â To delete a Data Item: 

1. Select a data item in the Data Item Definition dialog box. The Data Item is 
highlighted. 

2. Click the Delete icon. The data item is deleted.  

3. Alternatively, all data items can be deleted by clicking the Delete All icon. 

GENERATING AN FD FILE 
Once all the variables have been specified for the file the file must be generated 
before the file can be viewed. 
NOTE It is ness to regenerate a file after it has been altered. A file that has been altered 

and that needs to be regenerated will be marked with an * in the Project 

Workspace. 

Â To generate an FD file: 

1. Select the file that is to be generated from the Data View in the Project 
Workspace. The File Designer will appear in the Canvas Area. 

2. Click the Definition tab. The Definition dialog box appears.  

3. Right click anywhere in the Definition dialog box of the File Designer. A 
drop down list appears. 

4. Select Generate FD/SL from the drop down list. Messages will appear in the 
Build portion of the Output Window detailing the status of file generation. 

VIEWING AN FD FILE 
After all the file variables have been set and the file has been generated, the file can 
then be viewed in the Code Editor of DCIBench. 
NOTE It is ness to regenerate a file after it has been altered. A file that has been altered 

and that needs to be regenerated will be marked with an * in the Project 

Workspace. 
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Â To view an FD file: 

1. Select the file that is to be viewed from the Data View in the Project 
Workspace. The File Designer will appear in the Canvas Area. 

2. Click the Definition tab. The Definition dialog box appears. 

3. Right click anywhere in the Definition dialog box of the File Designer. A 
drop down list appears. 

4. Select View *.fd from the drop down list. The file will appear in the Code 
Editor in the Canvas Area. 

 

©Copyright 1995-2008 CASEMaker Inc. 4-10 



1File Designer 4 

©Copyright 1995-2008 CASEMaker Inc. 4-11 

4.3 File Control 
Selections made and data entered on the File Control screen are combined to 
construct a SELECT statement that is generated into the associated SL COPY file. 

 

 

Setting File Controls 

The File Designer can be used to set FD file controls. The physical data can be 
assigned to a device, file organization can be specified, and the physical filename 

associated with the logical filename on the disk can be assigned. Ensure that the File 
Control page is displayed and select any of the options that follow. 

ASSIGNING PHYSICAL DATA TO A DEVICE 
DCIBench supports the assigning of physical data to a device. The device can be of 
an external origin or a dynamic device (a single disk reference spanning more than 
one physical disk volume). The file organization format chosen will have effect on 

the type of device that can be chosen.  
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Â To assign Physical Data to a Device: 

1. In the File Control section of the File Designer, select a device type from the 
Device drop-down list box. 

2. In the Name text box, enter a filename enclosed in quotes (“”) and add a 
suffix, for example, “advisor.dat" (a name without quotes will be treated as a 
variable). 

SPECIFYING A FILE FORMAT 
DCIBench supports six file organization formats, None, record sequential, line 
sequential, relative, indexed and sort supported by COBOL.  

Sequential files can only be accessed sequentially, that is, in the same order as they 
were originally written to the file. New records are always added to the end of the 
file. 

Relative files identify each record in a file by their ordinal position in the file. This 
allows the file to be accessed sequentially, randomly or dynamically (the file is 
accessed both sequentially and randomly). 

An indexed file is a file in which each record includes a primary key. To distinguish 
one record from another, the value of the primary key must be unique for each 
record. Records can then be accessed randomly by specifying the value of the record's 

primary key. Indexed file records can also be accessed sequentially and dynamically. 

Â To specify a file format: 

1. Select a file format from the Organization combo box located in the File 
Format section. The selected file format appears in the drop-down list box. 

a) If the Relative format was selected enter a name in the Relative key 
name text box. The Relative key name field becomes active only once 
the access mode for the file has been selected 

b) If the Indexed form was selected the Record key name section of the 
dialog box becomes active. 

SETTING AN ACCESS MODE 
Sequential, random and, dynamic are the three access modes that are supported.  
In the SEQUENTIAL access mode records are accessed in the same order that they 
were written to the file.  

In the RANDOM access mode, records are accessed according to the value of the 
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record key. 
In the DYNAMIC access mode records are accessed by using the appropriate I/O 

statements to switch between SEQUENTIAL and RANDOM access.    

Â To set an Access Mode: 

1. Select an access mode from the Access Mode combo box in the File 
Designer. The selected access mode appears in the drop-down list box. 

SETTING A LOCK MODE 
When sharing data in a multi-user environment, you need to prevent more than one 

user from changing the same data at the same time. Locking files and records enables 
FD/SL’s in a multi-user environment to share common files while maintaining data 
integrity. 

Â To set a Lock Mode: 

1. Select a lock mode from the Lock Mode combo box in the File Designer. 
The selected lock mode appears in the drop-down list box. 

SETTING ADVANCED OPTIONS 

Â To set advanced options: 

1. Click the Advanced button in the File Designer. The Advanced Options 
dialog box appears displaying the advanced options for the current format. 

2. After selecting the desired advanced options, click OK. The Advanced 
Options dialog box closes. 

SETTING FILE STATUS 
File status is a two-byte code that indicates how a file operation was completed; 

either successfully, or with some form of error. If an error occurs, file status indicates 
the cause of the error. 
If you have a file status data-item defined for a file, after every input/output 

operation on the file (OPEN, CLOSE, READ, WRITE, REWRITE, START and 
DELETE) the run-time system updates it to indicate how the operation completed. 
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ADDING A FILE CONTROL COMMENT 
Comments added to a file will appear in the generated SL file.  

Â To add a File Control comment: 

1. Click theComment button and enter the desired text in the Comment box 
that will be generated in the filename.sl file. 

Assigning Keys 

The File Designer can be used to assign data items as keys in the physical description 
of an index file and to rename, insert comments, or delete those keys.  
The different key types (primary key, alternate keys, and alternate unique key) can be 

set when more than one key has been assigned using the File Designer. The first key 
specified will become the primary key by default, and only one primary key can exist 
for each FD/SL file. DCIBench will assign a default name to a split key. 

ASSIGNING A KEY 

Â To assign a Key: 

1. Perform step 1, 2 or 3 and proceed to step 4, or proceed directly to step 5. 
Select a data item in the Field Descriptions list. The data item is highlighted. 

2. Shift+Click the desired data items in the Field Descriptions list to select a 
block of data items. The data items are highlighted. 

3. Crl+Click the desired data items in the Field Descriptions list to select non-
contiguous data items. The data items are highlighted. 

4. Click the Add icon; the data item(s) appear(s) in the Selected Fields list. 

5. Double-click the subordinate column in the Selected Fields to make a 
subordinate field name. 

6. Click the Add icon ( ); a key is added to the Key List. 

RENAMING A KEY 

Â To rename a Key: 

1. Select the key to be renamed from the Key List. 

2. Double-click on the Key Name column; the Key Name column is no longer 
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grayed-out and is made accessible. 

3. Enter a key name, click anywhere outside of the Key Name column, the key 
name is assigned, and appears in the Key Name column. 

SETTING A KEY TYPE 

Â To set a Key Type: 

1. Select a Key from the Key List and double-click the Type column, a drop-
down list box appears. 

2. Select AK (Unique) to set the key to be a unique Alternate Key. 

3. Select AK (Duplicate) to set the key to be a duplicated Alternate Key. 

4. Click anywhere outside of the Type column in the Key List, the key type is 
set and appears in the Key List. 

SUPPRESSING A KEY 

Â To set a suppress phrase: 

1. Select a Key from the Key List and double-click the Suppress column, a 
drop-down list box appears. 

2. Select Zero or Space to suppress the key. 

ADDING A COMMENT 

Â To add a Comment to a key: 

1. Select a Key from the Key List  

2. Double-click the Comment column. A large button appears. 

3. Click the button, the Comment dialog box appears. 

4. Enter the desired text comments in the Comment dialog box. 

5. Click OK, the comment is set. 

DELETING KEYS 
A single key or all of the keys can be deleted at the same time. When deleting a key, 

the data items are also removed from the Selected Fields box. 
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Â To delete key(s):  

1. Select the key to be deleted from the Key List; the key is highlighted.  

2. Click the Delete icon above the Key List dialog box; the key is deleted. 

3. To delete all keys click the Delete All icon above the Key List dialog box, all 
of the keys are deleted. 

GENERATING AN SL FILE 
Once all the variables have been specified for the file the file must be generated 
before the file can be viewed. 

NOTE It is ness to regenerate a file after it has been altered. A file that has been altered 

and that needs to be regenerated will be marked with an * in the Project 

Workspace. 

Â To generate an SL file: 

1. Select the file that is to be generated from the Data View in the Project 
Workspace. The File Designer will appear in the Canvas Area. 

2. Right click anywhere in the File Control dialog box of the File Designer. A 
drop down list appears. 

3. Select Generate FD/SL from the drop down list. Messages will appear in the 
Build portion of the Output Window detailing the status of file generation. 

VIEWING AN SL FILE 
After all the file variables have been set and the file has been generated, the file can 
then be viewed in the Code Editor of DCIBench. 
NOTE It is ness to regenerate a file after it has been altered. A file that has been altered 

and that needs to be regenerated will be marked with an * in the Project 

Workspace. 

Â To view an SL file: 

1. Select the file that is to be viewed from the Data View in the Project 
Workspace. The File Designer will appear in the Canvas Area. 

2. Right click anywhere in the File Control dialog box of the File Designer. A 
drop down list appears. 

3. Select View *.sl from the drop down list. The file will appear in the Code 

©Copyright 1995-2008 CASEMaker Inc. 4-16 



1File Designer 4 

©Copyright 1995-2008 CASEMaker Inc. 4-17 

Editor in the Canvas Area.  

4.4 DCI Functions  
 

 

Table Names 

By default the table name is the same as the FD file. The table name can be changed 

in the table field. The table name is case insensitive. The character limit for a table 
name is 32. 

Field Names 

By default the field names are the same as the corresponding entry in the Definition 

dialog box. The field name can be changed in the table field. The field name is case 
sensitive. The character limit for a field name is 32. 
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GROUP 

The GROUP directive assigns a group of items to a single column in the DBMaker 
table. This field is disabled if the active data item is a leaf. 

Â To group items: 

1. Select the file that is to be edited from the Data View in the Project 
Workspace. The File Designer will appear in the Canvas Area. 

2. Click the DCI tab. The DCI dialog box appears. 

3. Double click the Group field in the Record Description. A drop down list 
appears. 

4. Select TRUE from the drop down list. 

Setting Character Types 

Character types for the data can be set in the Types field of the DCI page. The 
following table outlines the options available to users. The table also shows the 

corresponding COBOL data type. DCIBench assigns a default character type but 
users are able to change the default character type if it is unsuitable. 
 

“TYPE” VALUE CORRESPONDING COBOL TYPE 
NumUnsigned pic 9(x). 

NumSignSep pic s9(x) sign is trailing separate 

NumSigned pic s9(x) or s9(x) sign is trailing 

NumSepLead pic s9(x) sign is leading separate 

NumLeading pic s9(x) sign is leading 

CompSigned pic s9(x) comp-2, signed-int , signed-long 

CompUnsigned pic 9(x) comp-2 

PackedPositive pic 9(x) comp-3 

PackedSigned pic s9(x) comp-3 

PackedUnsigned pic 9(x) comp-6 unsigned-int unsigned-long 

BinarySigned pic 9(x) comp-1 pic s9(x) comp-1 pic s9(4) comp-4 

BinaryUnsigned pic 9(x) comp-4 

NativeSigned pic s9(x) comp-5, signed-short 
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NativeUnsigned pic 9(x) comp-5, unsigned-short 

Float float , double 

Alphanum pic x(x) 

4.5 Using Triggers 
COBOL Triggers are very useful and powerful features of DCI. COBOL triggers 

can be used to automatically execute predefined COBOL program in response to 
specific I/O events, regardless of which user or application program generated them. 
COBOL triggers can be used to: 

• Implement business rules. 

• Create an audit trail for COBOL activities. 

• Derive additional values from existing data. 

• Replicate data across multiple files. 

• Perform security authorization procedures. 

• Control data integrity. 

• Define unconventional integrity constraints. 

Use the following directives to define a COBOL trigger in order to specify the 
COBOL program name to be called when an I/O event occurs. 

Setting Database Column Types 

Â To set the database column data type: 

1. Select the file that is to be edited from the Data View in the Project 
Workspace. The File Designer will appear in the Canvas Area. 

2. Click the DCI tab. The DCI dialog box appears. 

3. Double click the DB Type field in the Record Description area of the DCI 
dialog box. A drop down list appears. 

4. Select the database column type from the drop down list. If the data type 
selected was date the Date Format field becomes active. (Continue to step a 
to set the date format.) 
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a) Double click the Date Format field in the Record Description area of 
the DCI dialog box. 

b) Select a date format type from the drop down list or enter a date type in 
the Date Format field.  

Setting Conditional Data 

Users are able to set conditional data which allow the user choose which table will 

retrived at runtime. When setting conditions users must keep the following in mind: 

• When using the AND/OR operators users must follow the operators with a 
LEAF statement. 

Â Example : To set the following conditional statement “A>2 AND B<3”: 

NOTE The letters A and B represent columns on a table. 

1. Double click Click here for making record condition. The Condition 
button appears. 

2. Click the Condition button. The Condition Builder diaolg box appears. 

3. Click the And button. “and” appears in the Condition List. 

4. Click the Leaf button, “leaf” appears in the Condition List beneath “and”. 

5. Double click in the Left Operand field and select A from the drop down list. 

6. Double click the Operator field and select “>” from the drop down list. 

7. Double click the Right Operand field and enter 2 in the active entry field. 

8. Click the Leaf button again. “leaf” appears in the Condition List beneath the 
first “leaf” statement. 

9. Double click in the Left Operand field and select B from the drop down list. 

10. Double click the Operator field and select “<” from the drop down list. 

11. Double click the Right Operand field and enter 3 in the active entry field. 

12. The Preview field shows the finished expression. 

13. Click OK. The expression appears in the DCI page of the File Designer. 

Offset 

The Offset column of the DCI page is a read only column. This column denotes the 
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offset of each data item in a record. 

Size 

The Size column of the DCI page specifies the length of a data item in a record. 

DCIBench will assign a value for this column but users are able to edit the value if 
the default value is unsuitable. 

Closing FD/SL Files and the File Designer 

When many FD/SL files are open, multiple instances of the File Designer are also 

opened. Closing FD/SL files will also close the corresponding instance of the File 
Designer and release memory back to the system. 

Â To close an FD/SL file and the corresponding instance of File Designer: 

1. Right-click an opened FD/SL file from the Project Workspace; a pop-up 
menu appears. 

2. Select Close FD/SL. If any unsaved components exist a warning message will 
appear with the file type and <file name> information. At this point three 
options are available. 

a) Click Yes to save the changes. The changes will be saved and File 
Designer and the components will be closed. 

b) Click No to not save the changes. The changes will not be saved and 
File Designer and the components will be closed. 

c) Click Cancel to cancel the saving of the FD/SL file.  The File Designer 
and the components will remain open. 

Closing the File Designer 

The File Designer can be closed to release memory back to the system. 

Â To close the File Designer: 

1. Select File from the Menu Bar, a drop-down menu appears. 

2. Select Close, the changes are saved and the File Designer is closed 
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5 Extended XML 

The file containing a database table description must have the same name of the 
database table plus the “.xml” extension. It should be compliant with the following 

DTD (Document Type Description): 
 

<!ELEMENT table (key+, conditions*, field+, trigger?)> 
<!ATTLIST table 
          name CDATA #REQUIRED 
          type (idx|rel|seq) #REQUIRED 
          maxRecLen CDATA #REQUIRED 
          minRecLen CDATA #IMPLIED 
          keyCount CDATA #REQUIRED> 
 
<!ELEMENT key (segment+,part+)> 
<!ATTLIST key 
          segCount CDATA #REQUIRED 
          duplicate (true|false) #REQUIRED> 
 
<!ELEMENT segment EMPTY> 
<!ATTLIST segment 
          offset CDATA #REQUIRED 
          size CDATA #REQUIRED> 
 
<!ELEMENT part EMPTY> 
<!ATTLIST part 
          name CDATA #REQUIRED> 
 
<!ELEMENT conditions (condition+, and*, or*)> 
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<!ELEMENT condition (#PCDATA)> 
<!ATTLIST condition  
          number CDATA #REQUIRED 
          name CDATA #REQUIRED 
          op (eq|gt|lt|ge|le|ne|default) #REQUIRED> 
 
<!ELEMENT and (condition*, and*, or*)> 
<!ATTLIST and  
          number CDATA #REQUIRED> 
 
<!ELEMENT or (condition*, and*, or*)> 
<!ATTLIST or  
          number CDATA #REQUIRED> 
 
<!ELEMENT field (field*,occurs*)> 
<!ATTLIST field  
          name CDATA #REQUIRED 
          offset CDATA #REQUIRED 
          size CDATA #REQUIRED 
          type (NumUnsigned|NumSignSep|NumSigned|NumSepLead| 
                NumLeading|CompSigned|CompUnsigned| 
                PackedPositive|PackedSigned| 
                PackedUnsigned|BinarySigned|BinaryUnsigned| 
                NativeSigned|NativeUnsigned|Float|Alphanum) #REQUIRED 
          digits CDATA #IMPLIED 
          scale CDATA #IMPLIED 
          condition CDATA #IMPLIED 
          dbtype (date|binary|longchar|longbinary|serial) #IMPLIED 
          format CDATA #IMPLIED> 
 
<!ELEMENT occurs (field+,occurs*)> 
<!ATTLIST occurs  
          size CDATA #REQUIRED 
          number CDATA #REQUIRED> 

5.1 Tag Descriptions 
The descriptions for various XML tags found in DCIBench are outlined in this 
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chapter. 

<table> Tag  

The <table> tag comprises the description of a database table. It consists of five 

attributes; name, type, maxRecLen, minRecLen and, keyCount. All 
attributes are mandatory. 
 

<!ELEMENT table (key+, conditions*, field+, trigger?)> 
<!ATTLIST table 
          name CDATA #REQUIRED 
          type (idx|rel|seq) #REQUIRED 
          maxRecLen CDATA #REQUIRED 
          minRecLen CDATA #IMPLIED 
          keyCount CDATA #REQUIRED> 

 

ATTRIBUTE COMMENTS 

name 
This attribute specifies the name of the table. If DCIBench is used, 
this attribute is set in the Table field of the DCI section of the File 
Designer. 

type 

This attribute specifies the type of table. There are three types of tables 
that can be specified; idx (indexed), rel (relative) and, seq (sequential). 
If DCIBench is used, these values are set in the Organization combo 
box of the File Control section of the File Designer. 

maxRecLen This attribute indicates the maximum size of a record. 

minRecLen This attribute indicates the minimum size of a record. If no value is 
specified this value will assume the value of maxRecLen. 

keyCount 

This attribute specifies the number of declared keys in a table. This 
number much match the number of keys declared in the body of the 
program. If DCIBench is used, the value for this attribute can be 
checked in the Key list field of the File Control section of the File 
Designer.  

 

<key>Tag 

This tag must appear in the body of the <table> tag. It must appear as many 
times as specified in the keyCount attribute of the <table> tag. This tag has 

two attributes segCount and duplicate. All attributes are mandatory. 



 DCI for MFCOBOL User’s Guide1 

 

<!ELEMENT key (segment+,part+)> 
<!ATTLIST key 
          segCount CDATA #REQUIRED 
          duplicate (true|false) #REQUIRED> 
 

ATTRIBUTE COMMENTS 
segCount This attribute specifies the number of segments that comprise a key 

duplicate This attribute specifies if a key is unique or a duplicate. The only 
values accepted for this attribute are true or false. 

<segment> Tag  

This tag must appear in the body of the <key> tag. It must appear as many times as 

specified in the segCount attribute of the <key> tag. It has two attributes and both 
are mandatory. 
 

<!ELEMENT segment EMPTY> 
<!ATTLIST segment 
          offset CDATA #REQUIRED 
          size CDATA #REQUIRED> 

 

ATTRIBUTE COMMENTS 
offset This attribute specifies the offset of a segment in a record 

size This attribute specifies the size of a segment in a record. 

<part> Tag 

This tag must appear in the body of the <key> tag. It can appear as many times as 
necessary. Each tag represents a field name that composes the key. This tag has a 

single attribute, which is mandatroy: 
 

<!ELEMENT part EMPTY> 
<!ATTLIST part 
          name CDATA #REQUIRED> 

 

ATTRIBUTE COMMENTS 
name This attribute specifies the name of a field. 
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<conditions> Tag 

This tag must appear in the body of the <table> tag. It must appear only once if 
the table has different record formats. This tag has no attributes but in it’s body must 
contain some conditions in form of tags  <condition>, <and> and <or>. Each 

condition is identified by a number. At runtime, every field that has a condition 
number exists only when the corresponding condition is true. If DCIBench is used 
this value is set in the Record Description field in the DCI page of the File Designer.  
 

<!ELEMENT conditions (condition+, and*, or*)> 

<condition> Tag 

This tag appears in the body of one of the following tags: <conditions>, 
<and>, <or>. It represents a logical expression and has 3 attributes. All attributes 

are mandatory. 
 

<!ELEMENT condition (#PCDATA)> 
<!ATTLIST condition  
          number CDATA #REQUIRED 
          name CDATA #REQUIRED 
          op (eq|gt|lt|ge|le|ne|default) #REQUIRED> 
 
<!ELEMENT and (condition*, and*, or*)> 
<!ATTLIST and  
          number CDATA #REQUIRED> 
 
<!ELEMENT or (condition*, and*, or*)> 
<!ATTLIST or  
          number CDATA #REQUIRED> 
 

ATTRIBUTE COMMENTS 
number This attribute specifies the offset of a segment in a record 

name This attribute specifies the size of a segment in a record. 

op 
This attribute specifies the operator to use in stated comparisons: 

The following values are accepted: eq | gt | lt | ge | le | ne | default  
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“OP” VALUE COMMENTS 
eq The specified operator is “equal to”. 

gt The specified operator is ‘greater than”. 

lt The specified operator is “lesser than”. 

ge The specified operator is “greater or equal to”. 

le The specified operator is “lesser or equal to”. 

ne The specified operator is “not equal”. 

default The default condition applies when no other condition is true. 
 

The value to compare with the field content is contained as characters in the body of 
the tag. If this value contains characters reserved for XML, in particular < or &, 

they must be escaped (&lt; and &amp;). 

<field> Tag 

The <field> tag must appear in the body of a table field. This tag comprises the 
description of a database field. There are nine attributes that comprise this tag. 

 

<!ELEMENT field (field*,occurs*)> 
<!ATTLIST field  
          name CDATA #REQUIRED 
          offset CDATA #REQUIRED 
          size CDATA #REQUIRED 
          type (NumUnsigned|NumSignSep|NumSigned|NumSepLead| 
                NumLeading|CompSigned|CompUnsigned| 
                PackedPositive|PackedSigned| 
                PackedUnsigned|BinarySigned|BinaryUnsigned| 
                NativeSigned|NativeUnsigned|Float|Alphanum) #REQUIRED 
          digits CDATA #IMPLIED 
          scale CDATA #IMPLIED 
          condition CDATA #IMPLIED 
          dbtype (date|binary|longchar|longbinary|serial) #IMPLIED 
          format CDATA #IMPLIED> 
 

ATTRIBUTE DCI PAGE FIELD COMMENTS 

name Field Name This attribute specifies the name of a 
field in a table. 
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offset Offset This attribute specifies the offset of a 
field 

size Size This attribute specifies the size of a 
field. 

type Type 

This attribute specifies the data type of 
a field.  

The following types are valid: 
NumUnsigned | NumSignSep | 
NumSigned | NumSepLead | 
NumLeading | CompSigned | 
CompUnsigned | PackedPositive | 
PackedSigned | PackedUnsigned | 
BinarySigned | BinaryUnsigned | 
NativeSigned | NativeUnsigned | Float 
| Alphanum 

digits  

For numeric fields it specifies the 
number of digits in a field. 

For non-numeric fields it specifies the 
size of a field. 

scale  

For numeric fields it specifies the scale 
of a field, expressed a power of 10. 

For non-numeric fields this value is set 
to 0. 

condition Click here for making record 
condition 

This attribute specifies if a condition 
acts upon this field 

dbtype DB Type 
This attribute specifies the data type of 
a segment in a field. 

format Data Format This attribute specifies the size of a 
segment in a record. 

 

“TYPE” VALUE CORRESPONDING COBOL TYPE 
NumUnsigned pic 9(x). 

NumSignSep pic s9(x) sign is trailing separate 

NumSigned pic s9(x) or s9(x) sign is trailing 

NumSepLead pic s9(x) sign is leading separate 

NumLeading pic s9(x) sign is leading 

CompSigned pic s9(x) comp-2, signed-int , signed-long 

CompUnsigned pic 9(x) comp-2 
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PackedPositive pic 9(x) comp-3 

PackedSigned pic s9(x) comp-3 

PackedUnsigned pic 9(x) comp-6 unsigned-int unsigned-long 

BinarySigned pic 9(x) comp-1 pic s9(x) comp-1 pic s9(4) comp-4 

BinaryUnsigned pic 9(x) comp-4 

NativeSigned pic s9(x) comp-5, signed-short 

NativeUnsigned pic 9(x) comp-5, unsigned-short 

Float float , double 

Alphanum pic x(x) 
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6 Menu Bar Reference 

6.1 File Command Menu 
The File Menu contains commands that perform basic operations on files and 
workspaces in the DCIBench environment. 

New 

The New option in the File Menu faciliates the creation and importing of new 
projects, FD/SL files and templates. Clicking New in the File Menu opens the New 
dialog box. From the New dialog box the user has a choice of three tabs; the Project, 
FD/SL and File tab. The options available for each page is detailed in the tables 
below. 

THE PROJECT PAGE 
The New page in the New dialog box allows users to set options for creating a new 
project. 
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OPTION COMMENTS 

Blank This option allows users to open a blank project as a new 
project. 

Project Wizard This option allows users to utilize the project wizard when 
creating a new project 

Project name 
This field contains the name of the project being created. 
If users do not set a name in this field DCIBench will 
assign a name for the project. 

Location This field contains the file path for the project.  

FD path This field contains the file path for the FD/SL files for the 
project.  

XML path This field contains the file path for the XML files for the 
project. 

Open in new workspace Set this option to open new project in a new workspace. 

Add to current workspace Set this option to open new project in the active 
workspace. 

OK Click OK to save the information for the new project. 

Cancel Click Cancel to exit the Project page without saving. 

THE FD/SL PAGE 
The FD/SL page of New dialog box allows users to set options when creating or 
importing an FD/SL file to a project. The table below lists the options available in 

the FD/SL page of the New dialog box. 
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OPTION COMMENTS 

Blank This option allows users to open a blank project as a new 
project. 

Import from Files This option allows users to import FD/SL files from a user 
defined location. 

Import from Database This option allows users to import FD/SL files from a 
database. 

FD/SL name This field contains the name for the FD/SL file being 
created or imported.  

Unique prefix 
This field contains the unique prefix for the FD/SL being 
created or imported. The default value value is FDx, where 
x is a sequential number. 

File name This field contains the file name for the files being created 
or imported. All FD/SL files end with the “.xlt” extension. 

Location This field contains the file path for the project.  

Add to existing project This option allows the user to add the new or imported 
file to any active project in DCIBench. 

OK Click OK to save the information for the new project. 

Cancel Click Cancel to exit the Project page without saving. 

THE FILE PAGE 
The File page in the New dialog box allows users to set options for templates (or 
source code) for projects in DCIBench. All templates available to the user are 
displayed in the display window of the File page. The following page lists the options 

available in the File page. 
 

OPTION COMMENTS 
Blank Text This option allows users to open a blank template. 

Source Template This option allows users to open the source template 
provided with DCIBench. 

File name This field contains the file name for the files being created 
or imported. 

Location 

Specifiy the full directory path to the location in which the 
new file is to be saved. The default directory path is the 
FD folder in the extisting project directory. Click the 
button to the right of the Location field to browse for a 
directory path.  
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OK Click OK to save the information for the new project. 

Cancel Click Cancel to exit the Project page without saving. 

Open 

The Open option in the File Menu allows users to open an existing file. Selecting 
Open from the File Menu opens the Open dialog box. The options in the dialog 
box are listed in the table below. 
 

OPTION COMMENTS 

Look in This option allows users to locate and open the desired 
file. 

File name This field contains the file name for the files being opened. 

Files of Type This field allows users to select the type of file being 
opened. 

Open Click Open to open the selected file. 

Cancel Click Cancel to exit the Open dialog box without opening 
a file. 

Close 

Select Close from the File Menu to close a selected active file. 

Open Workspace 

The Open Workspace option in the File Menu allows users to open an existing 
workspace. Selecting Open Workspace from the File Menu opens the Open 
Workspace dialog box. The options in the dialog box are listed in the table below. 
 

OPTION COMMENTS 

Look in This option allows users to locate and open the desired 
workspace. 

File name This field contains the file name for the files being opened. 

Files of Type This field allows users to select the type of file being 
opened. 

Open Click Open to open the selected workspace. 
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Cancel Click Cancel to exit the Open dialog box without opening 
a workspace. 

Save Workspace 

The Save Workspace option in the File Menu allows users to save the active 
workspace.  

Close Workspace 

Select Close Workspace from the File Menu to close a selected active workspace. 

Save 

Select Save option to save the current file. The name of the current file is displayed 
to the right of the Save option. 

Save As 

The Save As option in the File Menu allows users to open an existing workspace. 

Selecting Save As from the File Menu opens the Save Data Layout As dialog box. 
The options in the dialog box are listed in the table below. 
 

OPTION COMMENTS 

Save in This option allows users to save the data layout in a 
selected location. 

File name This field contains the file name for the files being saved. 

Save as Type This field allows users to select the type of file being saved. 

Save Click Save to save the selected data layout. 

Cancel Click Cancel to exit the Save As dialog box without saving 
a data layout. 

Save All 

Select Save All option to save all changes made to all open files. 
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Page Setup 

The Page Setup options in the File Menu are used to set up a page before printing. 
Selecting this option will open the Page Setup dialog box. 
 

OPTION COMMENTS 

Header 

This option allows users to set the header options for a 
printed document. Click the Browse button next to the 
field for a list of options. 

Full Path Filename prints the full path and file name in 
the header. The code displayed in the Header field when 
this is selected is &U.  

Filename prints the file name in the header. The code 
displayed in the Header field when this is selected is &F.  

Page Number prints the page number in the header. The 
code displayed in the Header field when this is selected is 
&P.  

Current Time prints the time the document was printed 
in the header. The code displayed in the Header field 
when this is selected is &T.  

Current Date prints the date the document was printed in 
the header. The code displayed in the Header field when 
this is selected is &D.  

Left Align prints the header in a left alignment. The code 
displayed in the Header field when this is selected is &L.  

Center prints the header in a center alignment. The code 
displayed in the Header field when this is selected is &C.  

Right Align prints the header in a right alignment. The 
code displayed in the Header field when this is selected is 
&R. 

Footer 

This option allows users to set the footer options for a 
printed document. Click the Browse button next to the 
field for a list of options. 

Full Path Filename prints the full path and file name in 
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the footer. The code displayed in the Footer field when 
this is selected is &U.  

Filename prints the file name in the footer. The code 
displayed in the Footer field when this is selected is &F.  

Page Number prints the page number in the footer. The 
code displayed in the Footer field when this is selected is 
&P.  

Current Time prints the time the document was printed 
in the footer. The code displayed in the Footer field when 
this is selected is &T.  

Current Date prints the date the document was printed in 
the footer. The code displayed in the Footer field when 
this is selected is &D.  

Left Align prints the footer in a left alignment. The code 
displayed in the Footer field when this is selected is &L.  

Center prints the footer in a center alignment. The code 
displayed in the Footer field when this is selected is &C.  

Right Align prints the footer in a right alignment. The 
code displayed in the Footer field when this is selected is 
&R. 

Style 

This field allows users to select the printing style for the 
document. Click the drop down box for a list of options. 

Black and White prints the document in black and white.  

Color prints the document in color.  

Zebra prints the document using alternating gray and 
white stripes.  

Print line number Set the Print line number check box to have the line 
numbers printed on the document. 

Frame 

This option allows users to set the frame type for the 
document. 

None prints no frame  

Inner prints an inner frame  

Margins This option allows users to set the margins for the 
document. 
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OK Click OK to save the print set up information. 

Cancel Click Cancel to exit the Page Setup dialog box without 
saving. 

Printer Setup 

The Printer Setup option allows users to modify or view printer settings. Selecting 
Printer Setup from the File Menu opens the Printer Setup dialog box. 
 

OPTION COMMENTS 

Name This option allows users to select the of the printer to be 
set up  

Properties This option allows users to set the options for the selected 
printer. 

Paper This area allows users to select the paper size and the 
source. 

Orientation  Allows users to select the orientation (landscape or 
portrait) of the paper. 

Network This option allows users to select a printer from a network 
location. 

OK Click OK to save the printer set up information. 

Cancel Click Cancel to exit the Printer Setup dialog box without 
saving. 

 

Print Preview 

Users can preview documents before printing by selecting the Print Preview option 

in the File Menu. The Print Preview dialog box opens when Print Preview is 
selected from the File Menu. The table below lists the options available to the user in 
the Print Preview dialog box. 
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OPTIONS ACTION 
Print Clicking this button sends the active document to a 

printer. 

Next Page Clicking this button allows the user to advance to the next 
page in the active document. 

Prev Page Clicking this button allows the user to retreat to the 
previous page in the active document. 

Two Page Clicking this button allows the user to view to pages of the 
active document simultaneously. 

One Page Clicking this button allows the user to view a single page of 
the active document. This button is only active when the 
user has clicked the Two Page button and is viewing two 
pages from the active document. 

Zoom In Clicking this button allows the user to zoom in for a closer 
look at the active document. 

Zoom Out Clicking this button allows the user to zoom out for a 
broader look at the active document. 

Close Clicking this button closes the Print Preview page. 

 

Print 

Selecting the Print option from the File Menu sends the open document to the 
printer specified in the Printer Setup option. 

Recent Files 

The most recently opened files are are listed in the File Menu. To open a file simply 

click it in the File Menu. 

Recent Workspaces 

The most recently opened workspaces are are listed in the File Menu. To open a 
recent workspace simply click it in the Recent Workspaces submenu. 

Exit 

Selecting Exit from the File Menu shuts down DCIBench. State information is 
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saved and all files are closed before exiting. 

6.2 Edit Command Menu 
The Edit File Menu contains options for finding and replacing text, bookmark 

options and editting functions. 

Undo 

The Undo option reverses recent editing actions. 

Redo 

The Redo option reverses recent undo operations. 

Cut 

The Cut option removes the selected item and places it on the clipboard. 

Copy 

The Copy option copies the selected item and places it on the clipboard. 

Paste 

The Paste option places a selection that has been cut or copied to the clipboard into 

the active file. 

Delete 

The Delete option removes the selected item. 

Select All 

The Select All option selects all the elements in the active Code Editor window. 

©Copyright 1995-2008 CASEMaker Inc. 6-10 



1Menu Bar Reference 6 

©Copyright 1995-2008 CASEMaker Inc. 6-11 

Find 

The Find option allows users to find text strings in the active Code Editor window. 
Selecting Find from the Edit Menu opens the Find dialog box. The table below lists 
the options available in the Find dialog box. 

 

OPTIONS ACTION 
Find what Enter the text string to be search for in the Find what field.

Match case Set the Match case check box to find the exact specified 
text string. 

Regular expression 
Set the Regular expression check box and select an 
expression from the expression list to use an expression to 
facilitate the search. 

Wrap around search 
Set the Wrap around search check box to have the search 
start from the beginning of the document after the seach 
has reached the end of the document. 

Ignore `-' and `_' Set the Ignore `-' and `_' check box to direct the search 
operation to ignore hyphens and underscores. 

Direction 
Select the desired direction of the search using the Up and 
Down radio buttons in the Direction section of the dialog 
box. 

Find Next 
Click the Find Next button to search for the desired text 
string. Click the Find Next button again to find the next 
occurrence of the desired text string. 

Mark All 
Clicking the Mark All button will mark each line of text 
with the desired text string,in the Code Editor, with a 
bookmark. 

Find All 

Clicking the Find All button will  direct the search 
operation to find all occurences of the desired text. The 
results of the search will be displayed in the Find in Files 
pane of the Output Window. 

Cancel Clicking this button closes the Find dialog box. 

Find Next 

The Find Next option advances the user to the next occurrence of the selected item 

in the active document. 
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Find in Files 

The Find in Files option allows the user to locate text strings in files stored on drives. 
 

OPTIONS ACTION 
Find what Enter the text string to be search for in the Find what field. 

File types Select the type of file to be searched in the File types drop 
down list. 

Match case Set the Match case check box to find the exact specified 
text string. 

Regular expression 
Set the Regular expression check box and select an 
expression from the expression list to use an expression to 
facilitate the search. 

Where 

Select the Search in workspace radio button to search for 
the text string in a file that is in DCIBench.  
 
Select the Search in directories radio button to search for 
the text string in a specific directory. The Search 
directories options section of the dialog box becomes 
active. 

Look in Select the directory to be searched in the Look in field. Or 
click the Browse button for further search options. 

Include subdirectories Set the Include subdirectories check box to include the 
subdirectories in the search. 

Find 
Click the Find button to search for the desired text string. 
The results of the search are displayed in the Find in Files 
pane of the Output Window. 

Cancel Clicking this button closes the Find in Files dialog box. 

Replace 

The Replace option allows the user to replace items in the text with other items. 
Selecting Replace from the Edit Menu opens the Replace dialog box. The table 

below shows the list of options in the dialog box. 
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OPTIONS ACTION 
Find what Enter the text string to be search for in the Find what field.

Replace with Enter the replacement text string in the Replace with field 
that is to replace the text in the Find what field. 

Match case Set the Match case check box to find the exact specified 
text string. 

Regular expression 
Set the Regular expression check box and select an 
expression from the expression list to use an expression to 
facilitate the search. 

Wrap around search 
Set the Wrap around search check box to have the search 
start from the beginning of the document after the seach 
has reached the end of the document. 

Ignore `-' and `_' Set the Ignore `-' and `_' check box to direct the search 
operation to ignore hyphens and underscores. 

Direction 
Select the desired direction of the search using the Up and 
Down radio buttons in the Direction section of the dialog 
box. 

Find Next 
Click the Find Next button to search for the desired text 
string. Click the Find Next button again to find the next 
occurrence of the desired text string. 

Replace Click Replace to replace the text in the Find what field 
with the text in the Replace with field. 

Replace All Click Replace All to replace every occurrence of the text in 
the Find what field with the text in the Replace with field. 

Cancel Clicking this button closes the Find dialog box. 

Replace in Files 

The Replace in Files option allows the user to replace text strings in files stored on 
their drives. Selecting Replace in Files from the Edit Menu opens the Replace in 
Files dialog box. The table below shows the list of options in the dialog box. 
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OPTIONS ACTION 
Find what Enter the text string to be search for in the Find what field. 

Replace with Enter the replacement text string in the Replace with field 
that is to replace the text in the Find what field. 

File types Select the type of file to be searched in the File types drop 
down list. 

Match case Set the Match case check box to find the exact specified 
text string. 

Regular expression 
Set the Regular expression check box and select an 
expression from the expression list to use an expression to 
facilitate the search. 

Where 

Select the Search in workspace radio button to seach for 
the text string in a file that is in DCIBench. 
 
Select the Search in directories radio button to search for 
the text string in a specific directory. 

Look in Select the directory to be searched in the Look in field. Or 
click the Browse button for further search options. 

Include subdirectories Set the Include subdirectories check box to include the 
subdirectories in the search. 

Replace All Click Replace All to replace every occurrence of the text in 
the Find what field with the text in the Replace with field. 

Cancel Clicking this button closes the Find dialog box. 

 

Go to 

The GO to option allows users to designate a destination for the cursor in the active 
document.  
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OPTIONS ACTION 

Begin Moves the cursor to the beginning of the active Code 
Editor document.  

End Moves the cursor to the end of the active Code Editor 
document.  

Line 
Opens the Go To Line dialog box, which displays the total 
number of lines in the Code Editor document. Enter the 
number of the line where the cursor is to be positioned. 

Bookmark 

The Bookmark option allows users to set, navigate and delete bookmarks. All 
options are available from the Bookmark submenu. 
 

OPTIONS ACTION 

Toggle Bookmark This option allows users to insert/remove a bookmark 
into/from the Bookmark pane for the selected line. 

Go to Next Bookmark This option allows a user to automatically move the cursor 
to the next bookmarked line. 

Go to Previous Bookmark This option allows a user to automatically move the cursor 
to the previous bookmarked line. 

Clear All Bookmarks This option allows a user to clear all bookmarks from the 
active document. 

6.3 View Menu Commands 
The View Menu commands allow users to view or hide various tool bars and other 
components in DCIBench. 

Toolbars 

The Toolbars option in the View Menu allows users to hide or display the Standard, 
Editor and Launch toolbars. Setting these options in the Toolbars submenu displays 
the respective toolbar. Clearing these options hides the respective toolbar. 

The Toolbars option also allows users to customize the toolbars and even to create 
new toolbars. Selecting Customize from the submenu opens the Customize dialog 
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box. The toolbars can be displayed, hidden, modified and new toolbars can created 
from the Customize dialog box. External applications can also be added to the 

Launch bar from the Customize dialog box. 
The Toolbars submenu can also be accessed by right clicking on any of DCIBench’s 
toolbars. 

Status Bar 

Setting Status Bar in the View Menu displays the Status bar in DCIBench. Clearing 
this option hides the Status bar. 

Workspace 

Setting Workspace in the View Menu displays the Workspace window in 

DCIBench. Clearing this option hides the Workspace. This option can also be 
accessed from small pop up wind that appears by right clicking anywhere in the 
workspace. 

Output Window 

Setting Output Window in the View Menu displays the Output Window in 
DCIBench. Clearing this option hides the Output Window. This option can also be 
accessed from small pop up wind that appears by right clicking anywhere in the 

Output Window. 

Full Path Name 

Setting Full Path Name in the View Menu displays the full path name of the active 
file in the Code Editor. The path name is displayed in the Title bar. Clearing this 

option hides the full path name of the active file in the Code Editor. 

Ruler Bar 

Setting Ruler Bar in the View Menu displays the Ruler bar in the Code Editor. 
Clearing this option hides the Ruler Bar. 
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Line Number Pane 

Setting Line Number Pane in the View Menu displays the Line Number Pane in 
the Code Editor. Clearing this option hides the Line Number Pane. 

Bookmark Pane 

Setting Bookmark Pane in the View Menu displays the Bookamrk Pane in the Code 

Editor. Clearing this option hides the Bookmark Pane. Displaying the Bookmark 
Pane does not make bookmarks inert. Bookmark navigation is available to users. 
Users will simply be unable to view bookmarks with the Bookmark Pane. 

6.4 Format Menu Commands 
The following is a list of the Code Editor commands available in the Format menu 
command list. These commands will assit the user when modifiying or generating 
source code. 

Capitalize 

Selecting Capitalize from the Format Menu capitalizes uncapitalized words in a 
selection. 

Uppercase 

Selecting Uppercase from the Format Menu changes all lowercase characters in a 

selection to uppercase  

Lowercase 

Selecting Lowercase from the Format Menu changes all uppercase characters in a 
selection to lowercase.  

Comment Block 

Selecting Comment Block from the Format Menu allows users apply comments 
symbols in the Indicator area of a selected block of text in the Code Editor. 
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Uncomment Block 

Selecting Comment Block from the Format Menu allows users to remove comment 
markings from a block of text in source code that is currently marked for comment.  

Sequence Number 

Selecting Sequence Number from the Format Menu allows users to re-number 

source code and display the new numbering in the Sequence Number area of the 
Code Editor. Selecting this option opens the Sequence Number dialog box. The 
table below shows the options available to users. 

OPTIONS ACTION 

Make Setting the Make radio button allows users to set the 
starting number and interval number for line sequencing.  

Starting No. The Starting No. is the number that the Code Editor will 
use to begin numbering the line sequences of code. 

Interval The Interval is the number that the Code Editor will use to 
increase the numbering between lines of code. 

Clear This option allows users to clear all sequence numbering in 
the source code appearing in the Code Editor. 

All Set this radio button to re-number the entire source code 
document. 

Selection If a block of text from the source code has been selected 
this radio button is automatically set. 

Lines This option allows users to specify the lines of code to be 
effected by the numbering change. 

OK  Click OK to save and apply the sequence number options.  

Cancel  Click Cancel to exit the Sequence Number dialog box.  

Indent to Next 

Selecting Indent to Next from the Format Menu allows users to change the indent 
of the current line to match that of the next line.  

Indent to Previous 

Selecting Indent to Previous from the Format Menu allows users to change the 
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indent of the current line to match that of the previous line.  

ANSI to Terminal Format 

Toggles the foreground and background colors of source code between ANSI and 

terminal format, as was defined them in the Tools -> Options -> Code Editor -> 
Format options. 

6.5 Tools Menu Commands 
The Tools Menu commands allow users to launch external executable files, 

customize and create toolbars and set environment, Code Editor and Data Designer 
options. 

Launched Tools 

Selecting this option allows users to launch external executable files. This option is 

only active after users have defined the external executable files in the Customize 
dialog box. Selecting this options opens the Customize dialog box. 

Customize 

Selecting Customize opens the Customize dialog box. The Customize dialog box 

contains three tabs for setting various options. The Toolbars tab allows users to set 
options for displaying or hiding toolbars in DCIBench and options for creating new 
toolbars. The Commands tab allows users to modify new and existing toolbars with 

various toolbar commands. The Tools tab allows users to add links to external 
applications to allow for easy access. 

TOOLBARS TAB 
The Toolbars tab allows users to set options for displaying or hiding toolbars in 
DCIBench and options for creating new toolbars. The table below details the 
options available to users in the Toolbars tab of the Customize dialog box. 
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OPTIONS ACTION 

Toolbars 

The Toolbars window displays the toolbars available to 
users. Setting the check box next to a toolbar displays the 
toolbar in DCIBench. Clearing the check box next to a 
toolbar hides the toolbar. 

New 

Clicking the New buttn opens the New Toolbar dialog 
box. Enter a toolbar name in the Toolbar name field of the 
dialog box. Click OK and the toolbar’s name is displayed 
in the Toolbars window. And a new toolbar appears in the 
DCIBench environment. 

Delete This option allows users to delete a toolbar when it is no 
longer needed.  

Reset  Click Reset to return to the default setting for the toolbar 
selected in the Toolbars list.  

Reset All  Click Reset All to return to the default setting for all 
available toolbars.  

Close  Click Close to close the Customize dialog box. 

COMMANDS TAB 
The Commands tab allows users to modify new and existing toolbars with various 
toolbar commands. The table below details the options available to users in the 

Commands tab of the Customize dialog box. 
 

OPTIONS ACTION 

Categories 
The Categories window displays the categories the toolbar 
commands are grouped in. The commands are grouped 
according to their functionality. 

Buttons The Buttons area displays the toolbar commands available 
to the user. 

Close  Click Close to close the Customize dialog box. 

TOOLS TAB 
The Tools tab allows users to add links to external applications to allow for easy 
access. The table below details the options available to users in the Tools tab of the 

Customize dialog box. 
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OPTIONS ACTION 

Menu Contents The Menu Contents window displays the links to external 
applications that are currently available to the user. 

Delete Button 
The Delete buttonnb allows the user to remove a link to an 
external application. This action can also be performed by 
pushing the Delete key on the keyboard. 

New 
Click New to add an application to the Menu Contents 
list. This action can also be performed by pressing the 
Insert ley on the keyboard. 

Command Enter the full directory path and file name of the program 
to be run when this menu command is selected. 

Arguments 

If necessary, enter the appropriate arguments for the 
command. Select arguments for the command by clicking 
the button to the right of the Arguments field.  

File Path {FilePath} is the full path name of the files that 
are contained in the working project or folder.  

File Directory {FileDir} is the directory of files that are 
contained in the working project or folder.  

File Name {FileName} is the file name of the files that are 
contained in the working project or folder.  

Current Directory {CurDir} is the current directory 
containing the DCIBench application.  

Workspace Path {WkspPath} is the full path name of the 
current workspace.  

Project Directory {ProjectDir} is the directory containing 
the working project.  

Project Name {ProjectName} is the name of the working 
project.  

Working Directory 

Enter the path for the working directory from which the 
new command can be executed. Select the appropriate 
variables by clicking the button to the right of the Working 
Directory field.  

File Directory {FileDir} is the directory of files that are 
contained in the working project or folder.  

Current Directory {CurDir} is the current directory 
containing the DCIBemch application.  

Project Directory {ProjectDir} is the directory containing 
the working project.  

Context menu Enter the text to be displayed when selecting the Launched 
l f h l
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Tools option from the Tools Menu. 

Use output window 
Setting this option will display the output from the linked 
application in the Output Window of DCIBench. 

Prompt for argument 
Set this option to initiate a dialog box to open and specify 
options and arguments before opening the external 
program. 

Close  Click Close to close the Customize dialog box. 

6.6 Options 
DCIBench’s environment options are divided into several categories, which include, 
General, Template, Build, Keyboard and Prefix options. 

Options -> Environment -> General 

The General environment options for DCIBench allow the user to control: 

• the timing of the automatic save function 

• the Recently Used Files list  

• what the workbench loads when it is first started and when it opens a workspace 

• the default source file format 

• the translation of ASCII extended characters to Windows ANSI extended 
characters 
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OPTIONS ACTION 

Save option 

Check the Save option box to activate automatic saves. The 
Automatic save every:_____minutes text box becomes 
active.  

Enter a new value into the Automatic save 
every:_____minutes text box if the default setting of ten 
minutes is not suitable 

Recently used files list 
Allows the user to set the number of recently used files that 
will appear in the recently used files list that appears in the 
File Menu. 

Recently used workspaces list 
Allows the user to set the number of recently used files that 
will appear in the Recent Workspace list that appears in 
the File Menu. 

Show empty environment Setting this option directs DCIBench, on start up, to open 
no workspaces and thus open as an empty environment. 

Show new project dialog Setting this option directs DCIBench, on start up, to open 
the New dialog box. 

Reload last workspace Setting this option directs DCIBench, on start up, reload 
the last active workspace. 

Reload documents 
Setting this option directs DCIBench to reopen the 
documents that were open the last time the workspace was 
open. 

ANSI source format Directs source files to be treated as ANSI source format 
files. 

Terminal source format Directs source files to be treated as Terminal source format 
files. 

Translate to ANSI/OEM 

Causes DCIBench to translate extended ASCII characters 
that originate in the OEM environment to Windows ANSI 
extended characters. Characters are retranslated back to 
OEM when the document is saved.  

Save… Click Save … to save the current settings to a file that the 
user can specify.   

Load… Click Load … to retrieve  settings from a file that the user 
has specified.   

OK Click OK to save current settings. 

Cancel Click Cancel to close the Options dialog box without 
saving. 
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Options -> Environment -> Template 

Template environment options allow the user the to set preferences for: 

• use or bypassing of the New/File dialog box when creating new FD/SL’s or files 

• adding or customizing of templates for files 

OPTIONS ACTION 

New File Setting this option directs DCIBench to open the New 
dialog box every time a user tries to create a new file. 

New FD/SL Setting this option directs DCIBench to open the New 
dialog box every time a user tries to create a new FD/SL. 

Template for Allows users to select the type of template to be used from 
the drop down list. 

Add Click Add to add a template file. 

Delete Click Delete to remove a selected template file. 

Modify 

Click Modify to modify a template file. Clicking this 
button opens the Modify Template File Infromation dialog 
box. From the dialog box the files name, file path and user 
description of the file can be modified. 

Save… Click Save … to save the current settings to a file that the 
user can specify. 

Load… Click Load … to retrieve  settings from a file that the user 
has specified.   

OK Click OK to save current settings. 

Cancel Click Cancel to close the Options dialog box without 
saving. 

Options -> Environment -> Build 

Build environment options allow the user to control certain aspects of how 
DCIBench behaves when running tools or generating FD/SL files. 
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OPTIONS ACTION 

Always save all documents Set this option to direct DCIBench to save all files before a 
tool is run. 

Prompt before generating if the 
file is not DCI format 

Setting this option directs DCIBench to always display a 
confirmation dialog box before generating files if the file is 
not in DCI format. 

Skip generating if the file is not 
DCI format 

Setting this option directs DCIBench to always generating 
a file if the file is not in DCI format. 

Always overwrite anyway if the 
file exists 

Setting this option directs DCIBench to always overwrite 
exiting files when generating new files. 

Save… Click Save … to save the current settings to a file that the 
user can specify. 

Load… Click Load … to retrieve  settings from a file that the user 
has specified.   

OK Click OK to save current settings. 

Cancel Click Cancel to close the Options dialog box without 
saving. 

Options -> Environment -> Keyboard 

Keyboard environment options allow the user to view, define, redefine, or remove 
keyboard shortcut keys associated with DCIBench and DCIBench’s Code Editor 
commands. 
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OPTIONS ACTION 

Category 
Select the keyboard shortcut category, to be viewed, 
defined, redefined, or removed, from the Category drop 
down list. 

Reset All Click Reset All to have all shortcut keys reset to default 
settings. 

Command This field lists all of the workbench commands that belong 
to the selected category. 

Shotcut Key 
This field displays the currently assigned keyboard shortcut 
combination. If no keyboard shortcut combination has 
been assigned the field is blank.  

Shortcut key Enter keyboard short cut combinations in this field. 

Assign Click Assign after entering a shortcut combination in the 
Shortcut key field. 

Remove Click Remove to delete an assigned shortcut combination 
in the Shortcut Key field. 

Save… Click Save … to save the current settings to a file that the 
user can specify. 

Load… Click Load … to retrieve  settings from a file that the user 
has specified.   

OK Click OK to save current settings. 

Cancel Click Cancel to close the Options dialog box without 
saving. 

Options -> Environment -> Prefix 

Prefix environment options allow the user to change the default file prefix strings 

and the default working directory names that are applied when the user creates a new 
project, FD/SL or file. 
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OPTIONS ACTION 
Project prefix The prefix string applied to name of a new project. 

FD/SL prefix The prefix string applied to name of a FD/SL file. 

File prefix The prefix string applied to name of a new file. 

XML directory The name of the XML file directory 

FD directory The name of the FD/SL file directory 

Save… Click Save … to save the current settings to a file that the 
user can specify. 

Load… Click Load … to retrieve  settings from a file that the user 
has specified.   

OK Click OK to save current settings. 

Cancel Click Cancel to close the Options dialog box without 
saving. 

Options -> Code Editor -> General 

The General Code Editor options that can be set by the user include: 

• modifying the width of the Line Number pane 

• modifying the length of a line in the Code Editor 

• setting the delimiter options for saving in a Windows or Unix environment 

• setting the vertical block behavior 
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OPTIONS ACTION 
Line number pane width Allows uers to modify the width of the Line Number pane. 

Line length x columns  Allows users to modify the length of a line in the Code 
Editor. 

Save Record Delimiter as 
CR/LF  

Lets you choose the carriage return/linefeed (CR/LF) 
ASCII end-of-line marker used in MS-DOS for files.  

Save Record Delimiter as LF  Allows users to choose the linefeed (LF) ASCII end-of-line 
marker used in UNIX for files.  

Virtual Space  Allows users to determine the Code Editor's vertical block 
select behavior. 

Save… Click Save … to save the current settings to a file that the 
user can specify. 

Load… Click Load … to retrieve  settings from a file that the user 
has specified.   

OK Click OK to save current settings. 

Cancel Click Cancel to close the Options dialog box without 
saving. 

Options -> Code Editor -> Format 

Format Code Editor options allow the user to set options for: 

• setting the source file format 

• modifying the source file code 

• modifying the colour that identify each ANSI display field 

• customizing the text apperance of code types 

• designating the text string that is inserted in ANSI format when modifying 
source code 

©Copyright 1995-2008 CASEMaker Inc. 6-28 



1Menu Bar Reference 6 

©Copyright 1995-2008 CASEMaker Inc. 6-29 

OPTIONS ACTION 

Source format Allows uers to select the source format of the source code, 
whose apperence is to be modified. 

Modify code  

Check the Modify Code check box if the user wants to 
insert a specified character string in ANSI format columns 
73-80 when a line of code is added or modified. Enter the 
desired string to be inserted in the adjacent entry field. 

Enable  “Format” and 
“Highlight”settings 

Allows users to set or disable all colour functions in the 
Format page of the Options dialog box. 

Coulumns  Allows users to modify the column width of the editing 
area selected in the list box.  

Background  Allows users to determine the background colour of the 
editing area defined in the list box. 

Foreground Allows users to determine the foreground colour of the 
editing area defined in the list box 

Font Allows users to select the font to be displayed in DCIBench 
documents. 

Save… Click Save … to save the current settings to a file that the 
user can specify. 

Load… Click Load … to retrieve  settings from a file that the user 
has specified.   

OK Click OK to save current settings. 

Cancel Click Cancel to close the Options dialog box without 
saving. 

Options -> Code Editor -> Tabs 

Tabs Code Editor options allow the user to control support of the tabs in source 
code or automatically convert tabs in code to spaces. 
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OPTIONS ACTION 

Display tab character with 

Set the Display Tab character with check box to display a 
special character to indicate the location of a tab in the 
code. Insert a non-blank character in the accompanying 
entry field. 

Tab size  Allows user to define the default tab size. 

Source format 
Select a source format from the Source format drop down 
list. Different sets of tab stops can be set for each source 
format. 

Keep tabs Set the Keep Tabs radio button if the Code Editor is to 
support the insertion of tabs using the default tab size. 

Insert spaces 
Set the Insert spaces radio button if the Code Editor is to 
support the conversion of tabs to spaces or to set individual 
tab stops in the code. 

Tabs Enter the desired tab size in the Tabs field. Established tabs 
are listed in the window below the field. 

Add 
Allows users to add to tabs list. The tab size is set in the 
Tabs field.. 

Delete Allows users to remove a tab from the tabs list. 

Save… Click Save … to save the current settings to a file that the 
user can specify. 

Load… Click Load … to retrieve  settings from a file that the user 
has specified.   

OK Click OK to save current settings. 

Cancel Click Cancel to close the Options dialog box without 
saving. 

Options -> Code Editor -> Keyword 

Keyword Code Editor options allow the user to add, delete, and modify keyword 
sets. Several default keyword sets are listed in the Keyword Set drop-down list. The 
user can also associate an indent value with a keyword and set an auto-indent 

behavior. The indent value is applied to the line following the keyword. 
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OPTIONS ACTION 

Keyword Set 
This drop down box allows users to view the keyword sets 
for various types of code. Select the desired keyword set to 
be modified from the list. 

Add 

Click the Add button to add a keyword list. 

Clicking this button opens the Add Keyword Set dialog 
box. From this dialog box the user is able to assign the 
keyword set name, and whether the keyword set is 
imported from an existing keyword set, an external 
keyword set or if the keyword set is new. 

Delete Clicking this button removes a keyword set from the 
keyword set list. 

Delete (Del) 
This button allows users to remove a keyword from the 
keyword list, specified by the Keyword Set. 

New (Ins) 
This button allows users to add a keyword to the keyword, 
list specified by the Keyword Set. 

Keyword 
This field displays a keyword’s name. To modify a keyword 
name click the keyword in the Keyword list field and enter 
a new name. 

Indent value 
This field displays the indent value for keywords. To 
modify a keyword’s indent value click in the Indent Value 
field for the keyword and enter a new value. 

None  With this option, the cursor returns to column 1 of the 
next line after a carriage return.  

First nonblank  
With this option, a carriage return sends the cursor to the 
next line at the location of the first non-blank character in 
the previous line.  

Customized  With this option, the Code Editor applies the keyword 
indent values shown in the keyword list box.  

Save… Click Save … to save the current settings to a file that the 
user can specify. 

Load… Click Load … to retrieve  settings from a file that the user 
has specified.   

OK Click OK to save current settings. 

Cancel Click Cancel to close the Options dialog box without 
saving. 

Options -> Data Designer -> General 
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General Data Designer options allow the user to select the colours used to display 
linked items (items brought in via a COPY statement) included with the data 

designers. 
 

OPTIONS ACTION 

Copy file color 

This area allows users to select the colors used to show data 
items that are Linked to in a data structure (included via 
the Link to file option of the Add Item list). Linked items 
may themselves include COPY statements. Items included 
as the result of nested COPY statements can also be shown 
in a contrasting color. To set the color used by each level, 
double-click in the Text Color field of the desired level and 
select a color. 

Save… Click Save … to save the current settings to a file that the 
user can specify. 

Load… Click Load … to retrieve  settings from a file that the user 
has specified.   

OK Click OK to save current settings. 

Cancel Click Cancel to close the Options dialog box without 
saving. 

Options -> Data Designer -> Graphical 

Graphical FD Data Designer options allow the user to set the element prefix and the 
level-number interval settings for data items. 
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OPTIONS ACTION 

Set Element Prefix  Allows users to change the default prefix setting in the 
entry field.  

Elementary Level Settings  

Allows users to set the level-number intervals for the 
second, third, and fourth sub-item levels of generated code, 
as well as an interval for any subsequent levels. The first 
level stteing connot be altered. Settings are displayed in the 
window below the ElementaryLevel Settings area of the 
dailog box. 

Save… Click Save … to save the current settings to a file that the 
user can specify. 

Load… Click Load … to retrieve  settings from a file that the user 
has specified.   

OK Click OK to save current settings. 

Cancel Click Cancel to close the Options dialog box without 
saving. 

6.7 Window Menu Commands 
Window Menu commands allow users to manipulate the Canvas Area, which is 
shared by the Code Editor and the File Designer, for more efficient use. 

Split 

Selecting Split from the Window Menu splits the Code Editor window into two. 
This allows users to view separate portions of the same code simultaneously making 
code editing more efficient. 

Close All 

Selecting Close All from the Window Menu closes all active windows in the Canvas 
Area. 

Cascade 

Selecting Cascade from the Window Menu overlaps active windows for the upper 

left of the Canvas Area to the lower right. All file title bars are visible to the user 
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allowing for quick access to any window. 

Tile Horizontally 

Selecting Tile Horizontally from the Window Menu postions all active windows in 

a horizontal format. The most recently active file will appear in the upper left corner 
of the Canvas Area with the next most recently active window to the right of the first 
window, and so on. Windows do not overlap in this setting. 

Tile Vertically 

Selecting Tile Vertically from the Window Menu postions all active windows in a 
vertical format. The most recently active file will appear in the upper left corner of 
the Canvas Area with the next most recently active window directly below the first 

window, and so on. Windows do not overlap in this setting. 

Arrange Icons 

Selecting Arrange Icons from the Window Menu allows users to postion minimized 
title bar icons, for active windows, in the Canvas Area. 

Recent Windows 

The Window Menu displays recently active windows in order of activity. 

Windows 

Selecting Windows from the Window Menu opens theWindows dialog box. From 
the dialog box users are able to view all active windows and save, close, activate or 

cascade the windows in the list. 

6.8 Help Menu Commands 
The Help Menu commands give users access to information about utilizing 
DCIBench, as well as, copyright and identification information. 
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DCIBench Contents 

Selecting DCIBench Contents opens the DCIBench help file. The help file can 
provide useful information to users about using DCIBench. 

About DCIBench 

Selecting About DCIBench opens a dialog box which displays copyright and 

identification information about DCIBench. 
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7 Toolbar Reference 

Toolbars provide quick access to many of DCIBench’s editing, managing functions 
and access to external applications as well. 

Standard Toolbar 

The Standard toolbar is a palette of command buttons for the most commonly used 
word processing functions. Users can display or hide the Standard toolbar by 
choosing the View -> Toolbar -> Standard command. Users can also display or hide 

the Standard toolbar by right-clicking in the toolbar and choosing Standard, or by 
selecting Customize and then Standard in the Customize dialog box. The table 
below lists the toolbar commands and the asscociated Menu commands. 
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COMMAND BUTTON MENU EQUIVALENT ACTION 

 
File ->New 

The New button opens the 
New dialog box. Allows 
users to create new files, 
projects and templates. 

 
File -> Open 

The Open button opens the 
Open dialog box. This 
allows users to open existing 
files. 

 
File -> Save 

The Save button saves the 
active file using its current 
file name. The Save As 
dialog box appears if the file 
has not yet been saved,  

 
File -> Save All The Save All button saves 

all active files in DCIBench. 

 
File -> Print The Print button sends the 

active file to a printer. 

 
File -> Print Preview 

The Print Preview button 
allows a view on an active 
file before printing 

 
Edit -> Cut 

The Cut button removes 
the selected item and places 
it on the clipboard.. 

 
Edit -> Copy 

The Copy button places a 
copy of the selected item on 
the clipboard. 

 
Edit -> Paste 

The Paste button places a 
selection that has been cut 
or copied to the clipboard 
into the active file. 

 
Edit -> Undo The Undo button reverses 

recent editing actions. 

 
Edit -> Redo The Redo button reverses 

recent undo operations. 

 
View -> Workspace 

The Workspace button 
toggles the view of the 
workspace in DCIBench 

 
View -> Output Window The Output Window 

button toggles the view of 
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the Output window in 
DCIBench. 

 
N/A The Generate button 

generates FD/SL files. 

 
N/A The Refresh button 

refreshes files in DCIBench.

 
Help -> About DCIBench 

The About button displays 
the DCIBench 
identification and copyright 
information. 

Editor Toolbar 

The Editor toolbar commands allow users to quickly access commomly used text 
search and replace functions and bookmark management functions. 
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COMMAND BUTTON MENU EQUIVALENT ACTION 

 Edit ->Find 

The Find entry field allows 
users to enter the text 
string they want to find. It 
also allows users to select 
text from a drop-down list 
of recent search operations 

 

Edit -> Find Next The Find Next button 
advances the user to the 
next occurrence of the 
selected item in the active 
document. 

 

Edit -> Find in Files The Find in Files button 
allows the user to locate 
text strings in files stored 
on drives. 

 

Edit -> Replace The Replace button allows 
the user to replace items in 
the text with other items. 

 

Edit -> Replace in Files The Replace in Files 
button allows the user to 
replace text strings in files 
stored on drives. 

 
Edir -> Bookmark -> 

Toggle Bookmark 

The Toggle Bookmark 
button inserts a bookmark 
into the Bookmark pane 
for the selected line. 

 
Edit -> Bookmark -> 

Go to Next Bookmark 

The Go to Next 
Bookmark button allows a 
user to automatically move 
the cursor to the next 
bookmarked line. 

 
Edit -> Bookmark ->  

Go to Previous Bookmark

The Go to Previous 
Bookmark button allows a 
user to automatically move 
the cursor to the previous 
bookmarked line. 

 
Edit -> Bookmark ->  
Clear All Bookmarks 

The Clear All Bookmarks 
allows a user to clear all 
bookmarks from the active 
document. 
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Launch Toolbar 

From the Launch Toolbar users are able to execute external applications by clicking 
the icon for the application. Icons are defined in the Tools -> Customize -> Tools 
options. 
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8 Pop Up Menu 
Reference 

The pop up menu reference is a complete listing of all the pop up menus in 
DCIBench and the commands found in them. 

8.1 Toolbar Pop Up Menu 
Right click anywhere in any of the toolbars and the toolbar pop up menu appears. 
The following table outlines the options available from the menu. 
 

OPTIONS ACTION 

Standard Setting this option displays the Standard toolbar. Clearing 
this option hides the toolbar. 

Editor  Setting this option displays the Editor toolbar. Clearing 
this option hides the toolbar. 

Launch Setting this option displays the Launch toolbar. Clearing 
this option hides the toolbar. 

Customize Click Customize to open the Customize dialog box. Users 
are able to create and modify toolbars from the dialog box. 

8.2 Workspace Pop Up Menus 
The workspace has a number of pop up menus which aid the user in workspace and 

file management.  
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General Workspace Pop Up Menu 

Right click anywhere, except a file or project node, in the Workspace to make the 
Workspace pop up menu appear. 
 

OPTIONS ACTION 

Save Workspace Clicking the Save Workspace option in the menu saves all 
active files in the workspace. 

Clsoe Workspace Clicking the Close Workspace option in the menu closes 
the active workspace. 

Allow Docking 
Setting this option allows the docking of the Workspace 
window. Clearing this option allows the Workspace 
window to float. 

Hide Setting this option hides the Workspace window. 

Project Node Pop Up Menu 

Right click on a project node to make the Project node pop up menu appear. 
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OPTIONS ACTION 

New FD/SL 
Clicking the New FD/SL option in the menu opens the 
New FD/SL dialog box. From the dialog box users can 
create new FD/SL files or import FD/SL files to a project. 

Add FD/SL 
Clicking the Add FD/SL option in the menu opens the 
Add Data Layout to Project dialog box. From the dialog 
box users can import existing FD/SL files to a project. 

Refresh All 
Clicking the Refresh All option in the menu causes all of 
the project's XFD XML layout files (.xlt) to be rebuilt from 
their corresponding .fd .sl and .xml files.  

Generate All FD/SLs 
Clicking the Generate All FD/SLs option in the menu 
directs DCIBench to generate all FD, SL files for the 
project. 

Generate All XMLs Clicking the Generate All XMLs option in the menu 
directs DCIBench to generate all XML files for the project.

Generate All 
Clicking the Generate All option in the menu directs 
DCIBench to generate all FD, SL and XML files for the 
project. 

Delete Removes the current project and all associated files from 
the workspace. 

Close Project Closes and saves the active project and all it’s componet 
windows. 

Properties 

Opens the Project Properties dialog box. From the dialog 
box users can view the project name, project directory, the 
copy file path, and the working directories for FD, SL and 
XML files Only the project name and copy file path can be 
modified in this dialog box. 

File Node Pop Up Menu 

Right click on a file node in the Workspace to make the File Node pop up menu 

appear. 
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OPTIONS ACTION 

View file_name.fd Clicking the View file_name.fd option in the menu opens 
the selected FD file in the Code Editor. 

View file_name.sl Clicking the View file_name.sl option in the menu opens 
the selected SL file in the Code Editor. 

View file_name.xml Clicking the View file_name.xml option in the menu 
opens the selected XML file in the Code Editor. 

Browse file_name.xml Clicking the Browse file_name.xml option in the menu 
opens the selected XML file in the user’s web browser. 

Refresh file_name 
Clicking the Refresh file_name option in the menu directs 
DCIBench to rebuild the selected data layout from it’s 
corresponding .fd, .sl and .xml files.  

Generate file_name.fd Clicking the Generate file_name.fd option in the menu 
generates the selected FD file from the data layout. 

Generate file_name.sl Clicking the Generate file_name.sl option in the menu 
generates the selected SL file from the data layout. 

Generate file_name.xml Clicking the Generate file_name.xml option in the menu 
generates the selected XML file from the data layout. 

Open file_name Clicking the Open file_name option in the menu directs 
DCIBench to open the selected file in the File Designer. 

Save file_name.xlt Clicking the Save file_name.xlt option in the menu directs 
DCIBench to save the selected data layout. 

Delete file_name.xlt 
Clicking the Delete file_name.xlt option in the menu 
directs DCIBench to remove the selected data layout from 
the current project. 

Delete From Disk 
Clicking the Delete From Disk option in the menu directs 
DCIBench to remove the selected data layout from the 
disk. 

Properties 

Opens the Data Layout Properties dialog box. From the 
dialog box users can view the file name, the unique file 
prefix, the data layout directory, the FD file directory, the 
SL file directory, the XML file directory and the source 
type for the file. Only the file name and unique file prefix 
can be modified in this dialog box. 

8.3 Output Pop Up Window 
Right click anywhere in the Output Window to make the Output Window pop up 
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menu appear. 
 

OPTIONS ACTION 

Copy  Selecting Copy from the menu places a copy of the selected 
item on the clipboard. 

Clear  Selecting Clear from the menu clears all text from the 
active Output window.  

Select All  Selecting Select All from the menu selects all text in the 
active Output window.  

Save As  Selecting Save As allows users to save the contents of the 
active Output window to a file.  

Find in Objects  Selecting Find in Objecs allows users to locate text strings 
in the files that contain Property window elements.  

History  

This option toggles the way in which the output of a new 
action is placed in the Output Window. When History is 
set the output of the next action is added to the end of the 
existing output. When History is clear the contents of the 
Output Window are cleared before output from the next 
action.  

Previous Error  Selecting this option moves the cursor in the source code to 
the previous compilation error in the Output window list.  

Next Error  Selecting this option moves the cursor in the source code to 
the next compilation error in the Output window list.  

Allow Docking  Selecting this option allows users to toggle the Output 
window as floating or docked.  

Hide  This option allows users to display or hide the Output 
Window.  

8.4 Code Editor Pop Up Menus 
The Code Editor pop up menus allow users quick access to useful and often used 
code editing functions. 
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OPTIONS ACTION 
Undo The Undo option reverses recent editing actions. 

Redo The Redo option reverses recent undo operations. 

Cut The Cut option removes the selected item and places it on 
the clipboard.. 

Copy  The Copy option places a copy of the selected item on the 
clipboard. 

Paste The Paste option places a selection that has been cut or 
copied to the clipboard into the active file. 

Find  The Find option advances the user to the next occurrence 
of the selected item in the active document. 

Find Next  The Find Next option advances the user to the next 
occurrence of the selected item in the active document. 

Toggle Bookmark  The Toggle Bookmark option inserts a bookmark into the 
Bookmark Pane for the selected line. 

Open Copy File This option opens a COPY file from the selected source.  

Properties  

Opens the Properties dialog box. From the dialog box users 
can view the file name, the file size, the date of the most 
recent save, the file format, and display options for the 
Bookmark Pane, File Path Name, Ruler Bar and Line 
Number Pane. Only the file format, and display options for 
the Bookmark Pane, File Path Name, Ruler Bar and Line 
Number Pane can be modified in this dialog box. 

8.5 File Designer Pop Up Menus 
The File Designer pop up menus give users quick access to functions associated with 

FD, SL and XML files. 

File Defintion Tab Pop Up Menu 

Right click anywhere in the File Definition tab to make the File Definition tab pop 
up menu appear. 
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OPTIONS ACTION 

Add Item Before The Add Item Before option allows users to and an item 
before the selected entry. 

Add The Add option allows users to and an item after the 
selected entry. 

Add Sub-item The Add Sub-item option allows users to and a sub-item 
after the selected entry. 

Undo The Undo option reverses recent editing actions. 

Redo The Redo option reverses recent undo operations. 

Cut The Cut option removes the selected item and places it on 
the clipboard.. 

Copy  The Copy option places a copy of the selected item on the 
clipboard. 

Paste The Paste option places a selection that has been cut or 
copied to the clipboard into the active file. 

Delete 
The Delete option allows users to remove the selected item 
or sub-item. It is important to remember that deleting an 
item or sub-item deletes all sub-items below in rank. 

Select All  This option allows users to select all items and sub-items 
appearing in the Data item definition list. 

Link Copy File  

The Link Copy File option allows users to link to the 
contents of another file. The contents of that file are 
included in a COPY statement when the generated file is 
compiled. The file can contain only data file descriptors. 

Import Copy File 
The Import Copy File option allows users to copy the 
contents of another file. The imported file can contain only 
data file descriptors. 

Open Copy File This option opens a COPY file from the selected source. 

Remove Copy File This option allows users to delete a link to another file. 

Reload Copy Files The Reload Copy Files option allows users to reload the 
contents of the selected COPY files. 

View file_name.fd The View file_name.fd option opens the active SL file in 
the Code Editor. 

Generate FD/SL The Generate FD/SL option generates the FD/SL files 
form the data layout. 
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File Control Tab Pop Up Menus 

MAIN POP UP MENU 
Right click anywhere, except the Key list area, in the File Control tab to make the 
File control tab pop up menu appear. 

OPTIONS ACTION 
Undo The Undo option reverses recent editing actions. 

Redo The Redo option reverses recent undo operations. 

View file_name.sl The View file_name.sl option opens the active SL file in 
the Code Editor. 

Generate FD/SL The Generate FD/SL option generates the FD/SL files 
form the data layout. 

 

KEY LIST POP UP MENU 
Right click anywhere in the Key list area of the File Control tab to make the Key list  
pop up menu appear. 
 

OPTIONS ACTION 
Add This option allows users to add a key to the Key list. 

Undo The Undo option reverses recent editing actions. 

Redo The Redo option reverses recent undo operations. 

Modify 
This option allows users to modify the selected key in the 
Key list. 

Delete  The Delete option allows users to remove the selected key 
from the Key list. 

Delete All The Delete All option allows users to remove all keys form 
the Key list. 

Select All The Select All option allows users to select all keys in the 
Key list. 

View file_name.sl The View file_name.sl option opens the active SL file in 
the Code Editor. 

Generate FD/SL The Generate FD/SL option generates the FD/SL files 
form the data layout. 
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DCI Tab Pop Up Menu 

Right click anywhere in the DCI tab to make the DCI tab pop up menu appear. 

OPTIONS ACTION 
Undo The Undo option reverses recent editing actions. 

Redo The Redo option reverses recent undo operations. 

View file_name.xml The View file_name.xml option opens the active SL file in 
the Code Editor. 

Browse file_name.xml The Browse file_name.xml option opens the active XML 
file in the users web brower. 

Generate XML The Generate FD/SL option generates the FD/SL files 
form the data layout. 
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9 Key Board Shortcut 
Reference 

9.1 Introduction 
DCIBench allows users to define keyboard shortcuts for most DCIBench 
commands. The Tools -> Options -> Environment -> Keyboard dialog box lists all 

DCIBench keyboard shortcuts.  

9.2 Main: Default Keyboard 
Shortcuts 
Selecting Main from the Category drop down list box in the Tools -> Options -> 
Environment -> Keyboard dialog box lists the keyboard shortcuts for toolbar, pop 

up menu and menu commands. 
The Command column in the table is the name assigned to the shortcut command. 
The Shortcut Key  column lists the keyboard key combination required to initiate 

the shortcut. A blank entry in this column denotes that the user must assign a 
keyboard key combination to use the shortcut. 
The Action column describes the action that is performed when the shortcut is 

initiated. 
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COMMAND SHORTCUT KEY ACTION 

About DCIBench  
Displays DCIBench 
copyright, registration 
and contact information 

AddFD  
Add a data layout to the 
current project. 

AddItem  
Add a data item to the 
record definition in the 
File Designer. 

AddItemBefore  

Add a data item before 
the selected item in the 
File Designer's record 
definition. 

AddKey  
Add a key for an indexed 
file in the File Designer.  

AddSubItem  

Add a subitem to a group 
data item in the File 
Designer's record 
description.  

ApplicationExit Ctrl + E 
Quit the application, and 
prompt to save the 
documents.  

BookmarkClearAll Ctrl + Shift + F2 Clear all bookmarks.  

BookMarkNext F2 
Move the cursor to the 
line containing the next 
bookmark  

BookmarkPrev Shift + F2 
Move the cursor to the 
line containing the 
previous bookmark.  

BookmarkToggle Ctrl + F2 
Toggle the display of a 
bookmark on the current 
line.  

BrowseXMLFile  
Browse the generated 
XML in the web browser. 

CharBackTab Shift + Tab 
Move the cursor back one 
tab stop.  

CharLeft Left Arrow 
Move one character to 
the left. 

CharLeftExtend Shift + Left Arrow Select one character to 
h l f
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the left. 

CharRight Right Arrow 
Move one character to 
the right. 

CharRightExtend Shift + Right Arrow 
Select one character to 
the right. 

CharTab Tab 
Move the cursor forward 
one tab stop.  

CloseFDSL  
Close and save the active 
FD/SL file. 

CloseProject  
Close and save the active 
project. 

CommentBlock  
Apply comment symbols 
to the selected block of 
text.  

Copy Ctrl + C 
Copy the selection to the 
clipboard.  

Cut Ctrl + X 
Cut the selection and 
move it to the clipboard. 

Delete Del Delete the selection.  

DeleteAllKey  
Delete all the keys in the 
File Designer's Key list.  

DeleteBack Backspace 
Delete the selected text or 
the character to the left of 
the cursor.  

DeleteFromDisk  Delete the file from disk. 

DeleteLine Ctrl + Shift + Z Delete the selected line.  

DockingProjectManager  
Dock the Workspace 
window.  

DocumentEnd Ctrl + End 
Move the cursor to the 
end of the document.  

DocumentEndExtend Ctrl + Shift + End 
Select the text from the 
current cursor position to 
the end of the document. 

DocumentStart Ctrl + Home 
Move the cursor to the 
beginning of the file.  

DocumentStartExtend Ctrl + Shift + Home 
Select the text from the 
current cursor position to 
the start of the document. 
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FileClose Ctrl + Q Close the file. 

FileCloseWorkspace  Close the workspace.  

FileOpen Ctrl + O 
Open an existing source 
file. 

FileOpenWorkspace  
Open an existing 
workspace 

FilePageSetup Ctrl + M 
Open the Page Setup 
dialog box.  

FilePrint Crtl + P Print the active file.  

FilePrintPreview  
Display full pages in print 
preview.  

FilePrintSetup Ctrl + K 
Open the Print Setup 
dialog box.  

FileProperties  
Display file properties in 
the Properties dialog box. 

FileSave Ctrl + S Save the active file.  

FileSaveAll  Save all open files.  

FileSaveAs  
Open the Save As dialog 
box.  

FileSaveWorkspace  
Save the current 
workspace.  

Find Ctrl + F 
Find the specified text in 
the active file.  

FindInFiles  
Find the specified text in 
the workspace or other 
designated directory.  

FindNext F3 
Find the next occurrence 
of the specified text.  

FindPrev Shift + F3 
Find the previous 
occurrence of the 
specified text.  

FindReplace Ctrl + H 
Find the specified text 
and replace it with 
another designated string.  

GenerateProjectBoth  
Generate code for all 
FD,SL and XML files in 
the active project.  

GenerateProjectFDSL  Generate code for all FD 
d f l h
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and SL files in the active 
project.  

GenerateProjectXML  
Generate code for all 
XML files in the active 
project. 

GenerateBoth  
Generate code for FD,SL 
and XML files for the 
selected data layout.  

GenerateFDSL  
Generate code for the FD 
and SL files for the active 
data layout. 

GenerateXML  
Generate code for the 
XML file for the active 
data layout. 

GotoLine Ctrl + G 
Move the cursor to the 
specified line of code. 

Help F1 
Display the help topics 
table of contents. 

HelpTopics  
Display the help topics 
table of contents. 

Home Home 
Move the cursor to the 
start of the current line. 

HomeExtend Shift + Home 

Select the text from the 
current cursor position in 
a line to the start of that 
line. 

ImportCopyFile  
Import a COPY file into 
the specified File 
Designer file descriptor. 

IndentToNext  
Indent the selected line to 
match the indentation of 
the next line. 

IndentToPrev  
Indent the selected line to 
match the indentation of 
the previous line. 

InsertMode Ins 
Toggle insert mode in the 
Code Editor. 

LineDown Down Arrow 
Move the cursor down 
one line.  

LineDownExtend Shift + Down Arrow Select the text from the 



 DCI for MFCOBOL User’s Guide1 

current cursor position 
down one line.  

LineEnd End 
Move the cursor to the 
end of the current line.  

LineEndExtend Shift + End 
Select the text from the 
current cursor position to 
the end of the line.  

LineUp Up Arrow 
Move the cursor up one 
line 

LineUpExtend Shift + Up Arrow 
Select the text from the 
current cursor position 
up one line.  

LinkCopyFile  
Link to a specified file 
descriptor from the File 
Designer.  

ModifyKey  
Change a key in the 
specified file descriptor in 
the File Designer.  

New Ctrl + N 
Create a new project, 
source file, or file 
descriptor.  

NewFD  
Create a new data layout 
(.xlt) file.  

NewLine Ctrl + Shift + I 
Insert a new line above 
the current cursor line.  

OpenCopyFile  
Open the designated 
COPY file.  

OutputClear  
Clear the contents of the 
Output Window.  

OutputHistory  
Display the output 
history of a file in the 
Output Window 

PageDown Page Down 
Move the cursor down 
one page. 

PageDownExtend Shift + Page Down 
Select the text from the 
current cursor position 
down one page. 

PageUp Page Up 
Move the cursor up one 
page. 
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PageUpExtend Shift + Page Up 
Select the text from the 
current cursor position 
up one page. 

Paste Ctrl + V 
Paste the selection from 
the clipboard to the active 
file. 

ProjectProperty  
Display the active 
projects properties in the 
Properties dialog box. 

Property  
Display the properties for 
the active object in the 
Properties dialog box. 

Redo Ctrl + Y 
Reverse the most recent 
Undo operation.  

RefreshDataFile  

Refresh the current 
source file. 

RefreshAllDataFile  
Refresh all the 
workspace's source files.  

ReloadCopyFile  
Reload the COPY file for 
the active file. 

RemoveCopyFile  
Remove a COPY file 
from the active file. 

ScrollDown  
Scroll the Code Editor 
window down one line.  

ScrollUp  
Scroll the Code Editor 
window up one line. 

SelectAll Shift + A 
Select all the elements in 
the active file.  

SelectionCapitalize  
Capitalize the selected 
text.  

SelectionLowercase Shift + U 
Lowercase the selected 
text.  

SelectionUppercase Ctrl + Shift + U 
Uppercase the selected 
text.  

SequenceNumber  
Generate the Sequence 
Number dialog box.  
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ToggleBookmarkPane  
Toggle the display of the 
Bookmark pane.  

ToggleFullPathName  
Toggle the display of the 
full pathname in the 
window title bar.  

ToggleLaunchToolbar  
Toggle the display of the 
Launch toolbar.  

ToggleLineNumberPane  
Toggle the display of the 
Line Number pane.  

ToggleOutputWindow  
Toggle the display of the 
Output window.  

ToggleProjectManager  
Toggle the display of the 
Workspace window. 

ToggleProjectToolbar  
Toggle the display of the 
Project toolbar.  

ToggleRulerBar  
Toggle the display of the 
Ruler Bar. 

ToggleStandardToolbar  
Toggle the display of the 
Standard Toolbar. 

ToggleStatusBar Ctrl + Shift+ S 
Toggle the display of the 
Staus Bar. 

ToolsCustomize  
Open the Customize 
dialog box. 

ToolsOptions  
Open the Options dialog 
box. 

TransposeSourceFormat  

Transpose the document 
display format between 
ANSI and terminal 
formats.  

UncommentBlock  
Remove comment 
symbols from the selected 
text.  

Undo Ctrl + Z 
Reverse previous 
operations.  

ViewFDFile  
Display the selected FD 
file in the Code Editor.  

ViewSLFile  
Display the selected SL 
file in the Code Editor. 

ViewXMLFile  Display the selected XML 
f l h d d
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file in the Code Editor. 

WindowArrangeIcons  
Arrange the caption bars 
of minimized windows at 
the bottom of the screen. 

WindowCascade  
Arrange open windows in 
a cascading format.  

WindowCloseAll  Close all open windows.  

WindowNextPane F6 
Activate the next pane in 
a split window.  

WindowPreviousPane Shift + F6 
Activate the previous 
pane in a split window.  

WindowSplit  Split the open window.  

WindowTileHorz  
Tile the open windows 
horizontally.  

WindowTileVert  
Tile the open windows 
vertically.  

WindowWindowsList  
Generate the Windows 
list box showing all open 
windows.  

WordLeft Ctrl + Left Arrow 
Move one word to the 
left. 

WordLeftExtend Ctrl + Shift +Left Arrow 
Select one word to the 
left. 

WordBackDelete Ctrl + B 
Delete the word to the 
left of the current cursor 
position.  

WordDelete Ctrl + D 
Delete the word to the 
right of the current cursor 
position. 

WordRight Ctrl + Right Arrow 
Move one word to the 
right. 

WordRightExtend Ctrl + Shift + Right Arrow 
Select one word to the 
right. 

 

9.3 Code Editor: Default Keyboard 
Shortcuts 
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Selecting Code Editor from the Category drop down list box in the Tools -> 
Options -> Environment -> Keyboard dialog box lists the keyboard shortcuts 

associated with the Code Editor environment. 
The Command column in the table is the name assigned to the shortcut command. 
The Shortcut Key  column lists the keyboard key combination required to initiate 

the shortcut. A blank entry in this column denotes that the user must assign a 
keyboard key combination to use the shortcut. 
The Action column describes the action that is performed when the shortcut is 

initiated. 
 

COMMAND SHORTCUT KEY ACTION 

BookmarkClearAll  Clear all bookmarks.  

BookMarkNext  
Move the cursor to the line 
containing the next 
bookmark  

BookmarkPrev  
Move the cursor to the line 
containing the previous 
bookmark.  

BookmarkToggle  
Toggle the display of a 
bookmark on the current 
line.  

CharBackTab  
Move the cursor back one 
tab stop. 

CharLeft  
Move one character to the 
left. 

CharLeftExtend  
Select one character to the 
left. 

CharRight  
Move one character to the 
right. 

CharRightExtend  
Select one character to the 
right. 

CharTab  
Move the cursor forward 
one tab stop. 

Code Template Ctrl + J 
Opens the Code Template 
list dialog box 

CommentBlock  
Apply comment symbols to 
the selected block of text. 
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Copy  
Copy the selection to the 
clipboard.  

Cut  
Cut the selection and move 
it to the clipboard.  

Delete  Delete the selection.  

DeleteBack  
Delete the selected text or 
the character to the left of 
the cursor. 

DeleteLine  Delete the selected line. 

DocumentEnd  
Move the cursor to the end 
of the document.  

DocumentEndExtend  
Select the text from the 
current cursor position to 
the end of the document.  

DocumentStart  
Move the cursor to the 
beginning of the file.  

DocumentStartExtend  
Select the text from the 
current cursor position to 
the start of the document.  

FilePrint  Print the active file.  

FilePrintPreview  
Display full pages in print 
preview.  

FileProperties  
Display file properties in the 
Properties dialog box. 

Find  
Find the specified text in the 
active file.  

FindNext  
Find the specified text in the 
workspace or other 
designated directory.  

FindPrev  
Find the next occurrence of 
the specified text.  

FindReplace  
Find the previous 
occurrence of the specified 
text.  

GotoLine Ctrl + G 
Move the cursor to the 
specified line of code. 

Home  
Move the cursor to the start 
of the current line. 
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HomeExtend  
Select the text from the 
current cursor position in a 
line to the start of that line. 

IndentToNext  
Indent the selected line to 
match the indentation of 
the next line. 

IndentToPrev  
Indent the selected line to 
match the indentation of 
the previous line. 

InsertMode  
Toggle insert mode in the 
Code Editor. 

LineDown  
Move the cursor down one 
line.  

LineDownExtend  
Select the text from the 
current cursor position 
down one line.  

LineEnd  
Move the cursor to the end 
of the current line.  

LineEndExtend  
Select the text from the 
current cursor position to 
the end of the line.  

LineUp  Move the cursor up one line 

LineUpExtend  
Select the text from the 
current cursor position up 
one line. 

NexrTabPosition  
Move the cursor to the next 
tab.  

NewLine  
Insert a new line above the 
current cursor line.  

OpenCopyFile  
Open the designated COPY 
file. 

PageDown  
Move the cursor down one 
page. 

PageDownExtend  
Select the text from the 
current cursor position 
down one page. 

PageUp  
Move the cursor up one 
page. 

PageUpExtend  Select the text from the 
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current cursor position up 
one page. 

Paste  
Paste the selection from the 
clipboard to the active file. 

PreviousTabPosition  
Move the cursor to the 
previous tab. 

Redo  
Reverse the most recent 
Undo operation. 

ScrollDown  
Scroll the Code Editor 
window down one line.  

ScrollUp  
Scroll the Code Editor 
window up one line. 

SelectAll  
Select all the elements in the 
active file.  

SelectionCapitalize  Capitalize the selected text. 

SelectionLowercase  Lowercase the selected text. 

SelectionUppercase  Uppercase the selected text. 

SequenceNumber  
Open the Sequence 
Number dialog box.  

TransposeSourceFormat  
Transpose the document 
display format between 
ANSI and terminal formats.

UncommentBlock  
Remove comment symbols 
from the selected text. 

VerbBlockMatch  
Move to the opposite end of 
a verb block command 
statement. 

WordLeft  Move one word to the left. 

WordLeftExtend  Select one word to the left. 

WordBackDelete  
Delete the word to the left 
of the current cursor 
position.  

WordDelete Ctrl + B 
Delete the word to the right 
of the current cursor 
position. 

WordRight Ctrl + D Move one word to the right.

WordRightExtend  Select one word to the right.
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Glossary 

API 
Application Programming Interface: The API is an interface between an application 
and an operating system.  
Binary Large Object (BLOB) 

A large block of data stored in the database that is not stored as distinct records in a 
table. A BLOB cannot be accessed through the database in the same way as ordinary 
records. The database can only access the name and location of a BLOB; typically, 

another application is used to read the data. 

Buffer 
A buffer is an internal memory space (zone) where data is temporarily stored during 

input or output operations. 

Client 
A computer that can access and manipulate data that is stored on a central server 

computer. 

Column 
A set of data in a database table defined as multiple records consisting of the same 

data type. 

Data dictionaries 
Also known as extended file descriptors; they serve as maps (links) between database 

schema and the file descriptors in a COBOL application. 
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Directive 
An optional comment placed in the COBOL code that sets the proceeding field or 

fields to a data type other than the default DCI setting. 

Field 
A part of a COBOL file descriptor roughly corresponding to a database column. It is 

a discrete data item contained in a COBOL record. 

File Descriptor 
A file descriptor is an integer that identifies a file that is operated on by a process. 

Operations that read, write, or close a file use the file descriptor as an input 
parameter. 

Indexed file 
Files containing a list of keys that uniquely identify all records. 

Key 
A unique value used to identify a record in a database. (See Primary Key for more 

details.) 

Primary key 
A primary key consists of a column of unique (or key) values , which can be used to 

identify individual records contained in a table. 

Query 
In DBMaker, SQL commands used to execute data query requests made by a user to 

obtain specific information.  

Record 
In COBOL, a group of related fields defined in the Data Division. In DBMaker, a 

record is also referred to as a row, and defines a set of related data items in table 
columns. 

Relational Database 
A relational database is a database system where internal database tables on different 
databases may be related to one another by the use of keys or unique indexes. 

Schema 
The structure of a database table as defined by its columns. Data type, size, number 
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of columns, keys, and constraints all define a table’s schema. 

Server 
A server is a central computer that stores and handles network configuration files, 
which also can consist of a database management system to store data (database) and 
distribute data to clients via a network connection. 

SQL 
Structured Query Language: The language which DBMaker and other ODBC 
compliant programs use to access and manipulate data. 

Table 
A logical storage unit in a database that consists of columns and rows used to store 
records. 

XFD file 
An acronym for extended file descriptor or data dictionary. It also forms the file 
extension for the data dictionary. 
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Index
B 

Bookmark Pane, 3-1 
Bookmarks 

using, 3-8 

C 

Character Types, 4-18 

Code Editor, 3-1 
Bookmark Pane, 3-1 
Line Number Pane, 3-1 

Ruler Bar, 3-1 
Code Editor Files 

open, 3-11 

Code Editor Options, 1-11 
Format, 1-12 
General, 1-11 

Keyword, 1-14 
Tabs, 1-13 

Code Editor Pop Up Menus, 8-5 

Code Editor Settings 
Format, 6-28 
General, 6-27 

Keyword, 6-30 
Tabs, 6-29 

Code Editor: Default Keyboard Shortcuts, 10 

Command Menu 

Edit, 6-10 
File, 6-1 
Format, 6-17 

Help, 6-34 
Options, 6-22 
Tools, 6-19 

View, 6-15 
Window, 6-33 

Commands 

Edit Menu, 3-3 
Editor Toolbar, 3-5 
File Menu, 3-2, 3-3 

Standard Toolbar, 3-4 
, 5-8 
COPY Files 

working with, 3-14 
Customize, 1-7 

D 

Data Designer Options, 1-15 
General, 1-15 
Graphical, 1-15 

Data Designer Settings 
General, 6-31 
Graphical, 6-32 

Database Column Types, 4-19 
, 5-8 
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DCI Tab Pop Up Menu, 8-9 
DCIBench 

GUI, 1-1 
Status Bar, 1-6 

Directives, 5-1 

USE GROUP, 4-18, 5-8 

E 

Edit Menu Commands, 3-3 

Bookmark, 6-15 
Copy, 6-10 
Cut, 6-10 

Delete, 6-10 
Find, 6-11 
Find in Files, 6-12 

Find Next, 6-11 
Go to, 6-14 
Paste, 6-10 

Redo, 6-10 
Replace, 6-12 
Replace in Files, 6-13 

Select All, 6-10 
Undo, 6-10 

Editor Toolbar, 7-3 

Editor Toolbar Commands, 3-5 
Environment Options, 1-7 

Build, 1-9 

General, 1-7 
Keyboard, 1-10 
Prefix, 1-10 

Template, 1-8 
Environment Settings 

Build, 6-24 

General, 6-22 
Keyboard, 6-25 

Prefix, 6-26 
Template, 6-24 

Extended XML, 5-1 

F 

File Control Tab Pop Up Menus, 8-8 
File Defintion Tab Pop Up Menu, 8-6 

File Descriptor Properties, 2-28 
File Descriptors, 2-16 

Import, 2-18 

Import from database, 2-21 
New, 2-16 

File Designer, 4-1 

Assigning Keys, 4-14 
Closing FD/SL Files, 4-21 
FD File Controls, 4-11 

FD/SL File Definitions, 4-3 
New FD/SL Files, 4-2 

File Designer Pop Up Menus, 8-6 

, 5-8 
File Generation, 2-29 

all FD/SL files, 2-29 

all files, 2-30 
all XMLs, 2-30 
individual FD/SL, 2-29 

XML, 2-30 
File Menu Command 

Close, 6-4 

Close Workspace, 6-5 
Exit, 6-9 
Open, 6-4 
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Open Workspace, 6-4 
Page Setup, 6-6 

Print, 6-9 
Print Preview, 6-8 
Printer Setup, 6-8 

Recent Files, 6-9 
Recent Workspaces, 6-9 
Save, 6-5 

Save All, 6-5 
Save As, 6-5 
Save Workspace, 6-5 

File Menu Commands, 3-2 
New, 6-1 

File Node Pop Up Menu, 8-3 

Format Menu Commands, 3-3 
ANSI to Terminal Format, 6-19 
Capitalize, 6-17 

Comment Block, 6-17 
Indent to Next, 6-18 
Indent to Previous, 6-18 

Lowercase, 6-17 
Sequence Number, 6-18 
Uncomment Block, 6-18 

Uppercase, 6-17 

G 

General Workspace Pop Up Menu, 8-2 

Generated Files 
modifying, 2-30 

H 

Headers and Footers, 3-9 
Help MenuCommands 

About DCIBench, 6-35 
DCIBench Contents, 6-35 

K 

Key Board Shortcut Reference, 1 

L 

Launch Toolbar, 7-5 
Line Number Pane, 3-1 

M 

Main: Default Keyboard Shortcuts, 1 
Matched Verb Block Command Lines, 3-18 
Menu Bar, 6-1 

Moving to a Specified Location, 3-7 

N 

, 5-8 

New 
dialog box, 6-1 

O 

OCCURS Clauses, 4-7 
Options Menu Commands 

Code Editor 
Format, 6-28 
General, 6-27 
Keyword, 6-30 
Tabs, 6-29 

Data Designer 
General, 6-31 
Graphical, 6-32 

Environment Settings 
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Build, 6-24 
General, 6-22 
Keyboard, 6-25 
Prefix, 6-26 
Template, 6-24 

Output Pop Up Window, 8-5 

Output Window, 3-2 

P 

Page Options, 3-9 

Headers and Footers, 3-9 
Pop Up Menu Reference, 8-1 
Print Preview, 3-19 

Programs 
Project Wizard, 2-3 

Project 

Delete, 2-15 
Project Node Pop Up Menu, 8-2 
Project Properties, 2-15 

Project Workspace 
Closing, 2-31 
Docking/Undocking, 1-5 

Saving, 2-30 
Projects 

Canvas Area, 1-6 

Closing, 2-31 
Menu Bar, 1-2 
Opening a Workspace, 2-2 

Output Window, 1-6 
Project Wizard, 2-3, 2-4 
Project Workspace, 1-4 

Toolbars, 1-2 

R 

REDEFINES Clause, 4-7 

Refreshing Files, 2-28 
Ruler Bar, 3-1 

S 

Source Code Templates, 3-14 
Split, 3-9 
Splitting the Window, 3-2 

Standard Toolbar, 7-1 
Standard Toolbar Commands, 3-4 
Status Bar, 1-6 

T 

Tabs 
using, 3-9 

Tag 
<conditions>, 5-5 

Tag Descriptions, 5-2 

Tags 
<condition>, 5-5 
<conditions>, 5-5 

<field>, 5-6 
<key>, 5-3 
<part>, 5-4 

<segment>, 5-4 
<table>, 5-3 

Text 

delete, 3-13 
moving, 3-12 
replace in all files, 3-17 

replacing, 3-16 
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search in all files, 3-17 
Search String Operators, 3-14 

searching for, 3-14 
selecting, 3-12 

Text Block Handling Functions, 3-13 

Text Case and Indent, 3-13 
Text Navigation, 3-6 
Toolbar Pop Up Menu, 8-1 

Toolbar Reference, 7-1 
Tools Menu Commands 

Customize, 6-19 

Lanched Tools, 6-19 
Triggers, 4-19 

U 

USE GROUP, 4-18 
, 5-8 

V 

View Menu Commands 
Bookmark Pane, 6-17 
Full Path Name, 6-16 

Line Number Pane, 6-17 

Output Window, 6-16 
Ruler Bar, 6-16 

Status Bar, 6-16 
Toolbars, 6-15 
Workspace, 6-16 

W 

Window Menu Commands 
Close All, 6-33 

Split, 6-33 
Windows Menu Commands 

Arrange Icons, 6-34 

Cascade, 6-33 
Recent Windows, 6-34 
Tile Horizontally, 6-34 

Tile Vertically, 6-34 
Windows, 6-34 

Wizards 

Project, 2-3 
Project Creation, 2-3, 2-4 

Workspace Pop Up Menus, 8-1 
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